"Unable to validate installation id." during install / No proxy

Hi there,

I feel like I’m in a different situation than everything I’ve been able to google on this issue. Also, self taught and my understanding of things is full of holes.

My problem is getting “Unable to validate installation id.” quasi instantly during install on my ubuntu 20.04 home server.

[email protected]:/opt/bitwarden$ ./bitwarden.sh install
 _     _ _                         _
| |__ (_) |___      ____ _ _ __ __| | ___ _ __
| '_ \| | __\ \ /\ / / _` | '__/ _` |/ _ \ '_ \
| |_) | | |_ \ V  V / (_| | | | (_| |  __/ | | |
|_.__/|_|\__| \_/\_/ \__,_|_|  \__,_|\___|_| |_|

Open source password management solutions
Copyright 2015-2022, 8bit Solutions LLC
https://bitwarden.com, https://github.com/bitwarden

===================================================

bitwarden.sh version 1.46.2
Docker version 20.10.12, build e91ed57
docker-compose version 1.29.2, build 5becea4c

(!) Enter the domain name for your Bitwarden instance (ex. bitwarden.example.com): ***.***.***

(!) Do you want to use Let's Encrypt to generate a free SSL certificate? (y/n): n

(!) Enter the database name for your Bitwarden instance (ex. vault): vault

1.46.2: Pulling from bitwarden/setup
Digest: sha256:47ab15e658ba482e31ed8d3c1ab6f7555d7be7a63de56cd74aa5920a01d8203c
Status: Image is up to date for bitwarden/setup:1.46.2
docker.io/bitwarden/setup:1.46.2

(!) Enter your installation id (get at https://bitwarden.com/host): ***

(!) Enter your installation key: ***

Unable to validate installation id.

Note there isn’t the “Problem contacting Bitwarden server.” part which I had sometimes when messing with the ~/.docker/config.json file (and which I eventually removed). This error took a couple seconds to popup, not like the “Unable to validate installation id.” I get which pops up instantly.

My UFW is open for 80/443, my subdomain’s DNS is setup to redirect to my Nginx server successfully showing the root default landing page (haven’t set a document root).

I’ve created a free org account on bitwarden.com with the email I’m using for getting the id/key.

I’m already running 4 other docker containers behind reverse proxys but I believe there shouldn’t be any ports conflicts:

PORTS
0.0.0.0:5000->5000/tcp, :::5000->5000/tcp
0.0.0.0:6881->6881/tcp, :::6881->6881/tcp, 58846/tcp, 0.0.0.0:8112->8112/tcp, 0.0.0.0:6881->6881/udp, :::8112->8112/tcp, :::6881->6881/udp, 58946/tcp, 58946/udp
0.0.0.0:7474->7474/tcp, :::7474->7474/tcp, 7473/tcp, 0.0.0.0:7687->7687/tcp, :::7687->7687/tcp
0.0.0.0:12000->80/tcp, :::12000->80/tcp

What am I missing to solve this issue? Let me know if I need to share more info or run different tests.

Cheers!

According to the pricing page, free orgs are not eligible for hosting in individual plans and teams are also ineligible in business plans.

Oh my, I’ll go hide myself for a while. I thought I looked long enough to that features comparison chart, didn’t pay attention to that bottom line though. Thanks.

EDIT: So I created another free individual account… but still have the same issue.

Is your IPV6 working (able to reach outside servers)? If it is not working, you might want to turn it off in docker. Had a similar issue recently, turning off IPV6 in docker solved it.

Hi Sugianto and thanks for chipping in - since installing via the default sh script doesn’t allow to modify that specific docker container launch command, I went ahead and deactivated ipv6 with the below.

~ ❯ sudo sysctl net.ipv6.conf.all.disable_ipv6
net.ipv6.conf.all.disable_ipv6 = 0
~ ❯ sudo sysctl net.ipv6.conf.default.disable_ipv6
net.ipv6.conf.default.disable_ipv6 = 0

But still getting the same error. Let me know if you had something different in mind?

Maybe try this:

set it to false.

No luck either…

Please check whether you can reach https://api.bitwarden.com from the container (and maybe from the host)

Getting a full traceroute from both the host and another docker container (not sure how to launch the bitwarden one since the install script fails before launching it). Same output in both cases (apart from step 1 below from docker):

[email protected]:/# traceroute api.bitwarden.com
traceroute to api.bitwarden.com (104.18.12.33), 30 hops max, 60 byte packets
1 172.17.0.1 (172.17.0.1) 0.088 ms 0.019 ms 0.014 ms
2 *** (192.168.1.1) 0.294 ms 0.439 ms 0.409 ms
3 10.193.232.17 (10.193.232.17) 3.552 ms 10.193.233.17 (10.193.233.17) 3.462 ms 3.489 ms
4 10.193.232.21 (10.193.232.21) 3.636 ms 3.884 ms 10.193.233.21 (10.193.233.21) 3.095 ms
5 *** (218.102.40.46) 3.546 ms *** (218.102.40.22) 3.527 ms *** (218.102.40.18) 3.822 ms
6 *** (123.255.90.246) 8.995 ms 7.521 ms 9.199 ms
7 104.18.12.33 (104.18.12.33) 3.504 ms 3.659 ms 3.471 ms

*** had to remove urls to post as a new user

This still seems like a connection issue to me. You can try running a blank ubuntu/debian image, install some of the network tools, then test it inside that container.