[Solved] Installation ID Validation Fails from Behind Proxy

I am trying to install on a server which is behind our corporate proxy. Although I have the proxy information set in my environment variables, I get the error “Unable to validate installation id. Problem contacting Bitwarden server.” during the installation id verification part of the install process.

I’ve looked through bitwarden.sh, but I don’t see an obvious place where I should set the proxy values.

How can I install bitwarden server from behind my company proxy?

This was my own error. Although I had httpProxy set in my docker config, I had forgotten httpsProxy.

I am encountering this same problem. However, my proxy configurations are correct and everything else seems to work.
Is the ID validation using a different protocol than http/s that my squid proxy isn’t handling?

I have the same problem as 0x_Sheepdog, can you describe where you put httpsProxy so that it worked? I can apparently download everything but when trying to validate the Installation key, it seems to ignore the proxy and just fails with

Unable to validate installation id. Problem contacting Bitwarden server.

Update: Apparently I was too keen on living on the bloody edge, used CentOS8. I made another attempt with CentOS7 and this time, the installation worked.