Import 1pux files from 1password

Feature name

Import support for .1pux files

Feature function

  • We currently allow to import 1pif files but this is not useful as 1password would only export 1pux and I no longer have access.
  • Since I can not export in any other format and no longer have access to the vault to try on other operating systems, I’m in a hard place where I am having to use the credentials from an unsecured 1pux archive (basically JSON)

Coming soon!

Thanks as always @djsmith85!

1 Like

Any ETA on when this will be available? It’s all I’m waiting to hop into BW.

HI @Johnny_Ciocca

All Pull Requests are in code-review phase
jslib - common library
web
cli

Once they are reviewed, they’ll move into quality assurance/testing.

I’m hoping to get this in for the upcoming release (~mid March), but if any issues are found during review or testing, it might get pushed out into the release after next.

I’ll post an update once I have more info.

1 Like

do you need some testers? srsly looking forward to this to ditch 1password

The pull requests have been reviewed and are queued up for testing by our QA team.

@Johnny_Ciocca Currently there is no way to give you access to test this, other than setting up your own development environment.

As long as no issues turn up during testing this should be included in the ~mid-March release.

1 Like

I see the funcionality was merged but import still needs to be rolled, is this correct? I couldn’t find it anywhere yet.

Hey @Johnny_Ciocca,

Yes the feature has been reviewed, merged and has passed testing by our QA team. It has been marked “Ready for Release” and will be included in the next release. Likely beginning/mid next week as mentioned.

Merging a Pull Requests just means it has passed code-review.

3 Likes

Thanks for all the patience and sorry to keep bothering you about this, Daniel!

Depending on your environment, there’s probably a beta program to sign up for, whenever it does get released. Of course, I think the web vault is always up to date.

yeah… if web is up to date, the proper option is missing on import. Only 1pif showing there.

Hey @cala and @Johnny_Ciocca and everyone else awaiting this:

I’m proud to announce the new importer supporting the .1pux format has been released.

More information about our releases can always be found on our release notes page.

Please make sure to update 1password to 8.5 or higher before exporting a .1pux-file.

We’ve had one report, so far where the import did not work for that user, which is being tracked here. If you are experiencing the same issue, please comment there.

For any other issue regarding the import please open a new issue here

I’d also love to get some feedback, if everything is working as expected.

Kind regards
Daniel

1 Like

of course I had to stumble into one error :sweat_smile:
I’m still trying to make sure I’m pinpointing it right, but it seems to be caused by a GPG record. I have the public key on the description and the private key attached. The error seems to be misleading, though: it says [212] [SecureNote] "<name>": The field Notes exceeds the maximum encrypted value length of 10000 characters. but when I wc -m both the description and the attached file, I get a total of less than 4k chars.

I did just read your comment on that issue about currently ignoring attachments, so it’s back to square one for trying to figure out what caused this… maybe I’m looking at the wrong entry?

(edit)
Just checking the unzipped file. The public block on description has exactly 6392 characters on the “notesPlain” field, and there’s the

"documentAttribues":{ 
  "fileName": "<filename>.asc",
  "documentId": "<id>",
  "decryptedSize": 11532
...

and I think this may be the limitation, correct? And yeah, if instead of downloading manually from the web interface of 1password (my account there is already frozen) I extract from the file, the size matches this bigger value than the one I found before.

Let me see if I can manually change the 1pux file to remove it, and reupload to Bitwarden

(edit2)
ok, that wasn’t all. There was, indeed, ANOTHER entry with the exact same name containing a HUGE line of “notesPlain”. After removing that entry completely, I was able to import my 1pux file without problems.

Now, to add back that entry I removed :eyes:

Hey @Johnny_Ciocca,

I’m happy to hear that you figured it out and that the import worked after removing that one entry.

The length restriction is for notes and custom fields and relates to the length of the encrypted string. The attachments I mentioned are proper attachments (.pdf, .jpg, etc), that would reside in the files-folder of the unzipped 1pux-file. Those are currently not imported.

1 Like

Yeah, I anticipated that and removed those files from my manual version.

One bad thing I noticed: “Archive” in 1password is kind of its recycle bin, the trash can. And when I imported, everything I had “archived” (deleted) came back to life, instead of going to the Thrash - I imagine this must have been decided because 1password’s Archive has no timeout on its entries, while Bitwarden’s Trash items get automatically deleted after 30 days.

I think it would be nice to have it imported to the Trash as it should, and a notification at the end of the importing process: “999 items were imported from 1password’s Archive, please check your Trash folder or items will be deleted in 30 days”?

We are skipping items marked as trashed, but I see that items can have a field state: "archived".

We could put that down for a future improvement. Thank you for mentioning it.

1 Like

Just tried importing the .1PUX file from 1Password v8.7. BitWarden said it was successfully imported, but then no data appeared. The entire vault is completely empty. What’s going on?

Hi @David_Fine and welcome to the community!

I’ve just tested importing a 1.pux-file freshly exported from 1password 8.7, and had no issues at all.

I’m assuming you followed the steps outlined here.

Does a logout and logging back in, show any items?

If you open the browser’s developer console while importing, are there any errors showing up, after the import says it’s completed?

If, no errors come up, is there anything you think might be special about your 1password content?

  • long notes
  • different language than English (cyrillic, umlauts, …)
  • a new item type/feature just introduced by 1password?

Just trying to narrow the scope.

Kind regards,
Daniel

Hi. Thanks for the quick reply. So an update! Tried importing again and again and finally, the vault appeared, but every item in triplicate. This suggests that they were imported each time, but for some reason not displaying. So I then deleted everything in the vault and tried importing again. This time, everything appeared as it should. So that’s great, but, a new problem…

When I installed the Safari browser extension and logged in, the vault is empty. Same account, but it’s empty in Safari. Went over to Firefox and installed the extension there and logged in. In Firefox, it loaded as it should and all my logins are there. Tried Chrome and that works fine too. Why does my vault show as empty in the Safari browser extension?

Hi @David_Fine I’m happy to hear, you were finally able to import everything.

I have not heard of any issues with the Safari browser or our extension in Safari, where it would show up empty.

That is really odd behaviour. Are you self-hosting? Older Mac or Safari version?

Kind Regards,
Daniel