Importing 1pux or csv - moving from 1password

I’m trying to move from 1P to Bitwarden. I have successfully exported the 1pux and a csv from 1P, but cannot get the 1pux to import into BW. At first it was saying that certain items exceeded the size or character limit, so I edited the file with a text editor (deleted any large blocks of text), then tried again to no avail. After editing I just get an error with no further info. I tried re-zipping and changing the file type back to 1pux, same result. I’ve read the instructions and other posts here, and it seems everyone else is talking about massaging the data, so they’re getting much further along than I am.

I can import the .csv file without issue, however it does not include URLs and therefore BW cannot not match entries to the website, and I have to search the vault rather than quickly auto-filling. The .exported csv does not contain the URL, as opposed to BW not importing it. Is this something I can fix during the 1P export?

All I really need is title, username, password, and url to be satisfied, however, I have nearly 1.000 entries and it would take forever to manually enter URLs. What I need is either detailed instructions so I can import the 1pux file correctly, or a way to export from 1P with URL included in the .csv (which is probably the easier of the two). Can anyone tell me how to make this work? Thank you!

@jtice1 Welcome to the forum!

You might try starting over with your unedited 1pux, and remove any embedded file attachments as described in this post.

Try the import again, and record the exact wording of the original error message (if any).

What error message did you get? Did it literally just say “error” and nothing else?

It sounds to me like you may have inadvertently corrupted the file when editing it.

Hi, is 1pux the 1password 8 export or the 1password 7 export? I exported from 1p 7 withough any worries. It didn’t import any attachments but bw make it clear that you have to add those yourself. I would generate a new export but exclude items that have attachments and see if that works. Good luck