How to get autofill to function for subdomains?

Hi,

Too many years i used Lastpass, and because your recent limitations, i started using Bitwarden !
One of good things in Lastpass, its that auto fill the correct credentials (login and password) !

Bitwarden in subdomais does not work well, today i clicked auto fill and save, but tomorow it fills with wrong password.

By example, our team has many subdomains
othersite.bw.com
informationsystem.bw.com

And in these different subdomains many times it suggest many logins, and auto fills with wrong login

I use Windows 10 and Firefox 88.

Hi @zefilipe - have you tried changing the match detection? I’ve found it works well but you just have to tweak things for sites where you want it to offer different options depending on subdomain…
image

More info at: Using URIs | Bitwarden Help & Support

I’ve come from LastPass too and am only gradually working out the power of Bitwarden! For example now I’ve started to get the hang of custom fields I’ve found it can even pre-fill specific characters from a PIN/password on a banking site, which LP wasn’t able to do :slight_smile:

1 Like

I even use the Custom Fields to fill in the data in [added] the web version of [/added] SAP forms. It is so much easier to just press Ctrl + Shift + L than to have to add a lot of static manually again and again.

1 Like

In the last days i used auto fill and save, and when open each tab after enter master password in bitwarden, auto fill with the credentials of other subdomain, and i have logins separated to each subdomain !

I’ve try to use “Default match detection” tomorrow, thanks :wink:

If you want it to match the whole subdomain, change “Match detection” to “Host”.

1 Like

Yesterday, i had make this changes using URI 1 as “Default match detetion”.
Today, after start browser and enter master password, the first subdomain does auto fill well, but the others no !

There has a way to fix this ?

I maked changes to use “Host” unless “Match detetion”, tomorrow i send feedback if that’s solved or not !
Thanks

Hi,
Yesterday i changed “Match detection” to “Host” in many work logins.

Today after start browser and enter master password, this results perfecty in the multiple subdomains, i’ve tested so many!

Finnaly i found solution, thank you :wink: :+1:

1 Like

Glad you got it sorted - it’s a great example of how good Bitwarden is once you’ve got the hang of the options :slight_smile: (PS I wasn’t suggesting to change to ‘default match detection’, more just highlighting this was the bit to change, see the help article I linked to for what all the options do)

2 Likes

Yeah, the match detection options are pretty powerful :slight_smile:

2 Likes