Help - Not working in Android 11 (works great for WIN10)

Using Pixel 3a XL
Android version 11
Battery optimization = “Not optimized”
Background restriction = “Background usage can’t be restricted”

Bitwarden Version 2.7.0 (3258)

None of the password features work in Android. A subset of broken things in the Android version of Bitwarden are:

  1. launching to a website from inside Bitwarden.
    1a) For instance the “Help and Feedback” button inside the bitwarden application.
    2a) When in “My Vault” pressing the three verticle circles provides the option to “Launch”. When Launch is pressed, the “View, Edit, Copy…, Launch” menu goes away but nothing is launched. So I can’t use the vault to enter the stored websites.

  2. The Bitwarden “Auto-fill services” are enabled, but the auto-fill does not work when I enter an account that does exist in “My Vault - Login”.

Does the Bitwarden features even work with Android? It works as advertised for WIN10.

2 Likes

Yep it is working fine for me. Both autofill and launch.

Thanks for the reply.
Damm - I have spent so much time and not working.

Try clearing cache and try again.

Will do. Just as a note, I do have Bitwarden selected as the autofill app for the phone.

1 Like

Thanks for the suggestion - Cache cleared but no joy.

Did you give allow Bitwarden app to draw over other apps?

Uninstall the app and reinstall it. That may be the only solution. Did you install the app from the Play Store itself?

Yep this can be the final and only solution if nothing else had worked.

1 Like

Thanks again for the idea. I did configure on phone to allow Bitwarden app to draw over other apps. I will open and check again just to make sure it stuck.

YES - Display over other apps - “Allowed”. I had also restarted the phone after all the recommended changes, confirmed they stuck but no joy.

I installed Bitwarden from Play Store. I will uninstall and reinstall. Keeping fingers crossed.

The Auto-fill service page is a new feature. There might be problems with it.
If the problem is still there, leave a reply.

1 Like

Yes I also used it just now. Working well. But I have doubts about Andoid 11

1 Like

Reinstalled Bitwarden, and reconfigured again with the following enabled:
Auto-fill Service - ENABLED.
Use Inline Autofill - ENABLED
Use Accessibility - ENABLED
Use Draw-over - ENABLED
Under Android Accessibility Bitwarden configured as follows:
“On/Assist with filling username and password fields in other apps and on the web”

Unfortunately, still no joy.

I have Verizon Digital Secure on the phone. I will turn off and check out.

Verizon has a security app?
Can you quickly read through this article https://bitwarden.com/help/article/auto-fill-android/

@tgreer a little help, please?

It was the Verizon Digital Secure app on the phone. Disabling it got it partly working where now I get a popup under the login showing, “Auto-fill with Bitwarden, Go to my vault”. So partial success. Still not working is launching websites saved in “My Vault - Login” then press the three vertical circles which then opens a pop-up showing the specific site url, along with the options below of , “View, Edit, Copy Username, Copy Password, Launch”. Pressing the Launch just makes the popup go away but nothing happens. Alternatively, if I View item and go to the “URIs” forward (square with a right arrow) nothing happens. The copy features in the menu DO work.

1 Like

vachan - thanks I will read thru the article now.

I did read through that. I configured as directed in article. I followed closely the first time, but will read again and make sure configured as in article.

Just curious, does your “URIs” forward function work where when you press on the square with a right arrow it takes you to the site?