How to enable Android 11 Autofill or make it work?

I have S20+ phone with the latest Android 11 just installed. I have Bitwarden 2.7.0 installed. I use Google’s gBoard keyboard. I have enabled “Auto-Fill Service”, “Use Inline Autofill”, “Use Accessibility” from the Auto-fill Services settings. Vault is unlocked.

When I click a field in a login form using Chrome, I don’t see any autofill option at all. Not over the keyboard, not in the screen.

i wonder what am I doing wrong or have I configured something wrong?

1 Like

I also see this issue intermittently on various Google Pixel devices, so I don’t think it’s device specific. My vault also locks on Android no matter what I set the timeout settings to.

Any tips? Which settings I need to have and how should the feature work? Should I get a clickable item on the top bar of my keyboard? I’m not seeing any on any site.

1 Like

It seems this is not working properly on Android Chrome 8 at all. On Android Firefox the inline autofill works a lot better. Not sure, however, if this is a Bitwarden or Chrome issue.

I can’t believe this works: try it on Chrome Beta from the Play Store, https://play.google.com/store/apps/details?id=com.chrome.beta . I saw someone on Reddit say it works 100% of the time there, but not in mainline Chrome; I installed it and bam, it works every time I’ve tried it now, with the IME (keyboard) autofill.

Good to hear that it will be fixed! I’ll, however, wait for the stable release.

1 Like

I have the exact same problem on my S10e with Chrome and GBoard. Good to see i‘m not alone.

Guess i‘ll just wait until Chrome updates? Did anyone find another solution?

I want to report that indeed: on Chrome 89 for Android the Inline Autofill finally works reliably! This is a very big improvement and I much prefer this over the popup (which actually makes some pages not usable by hiding page elements).

So, update Chrome and enjoy the new inline autofill and disable all other accessibility services from Bitwarden.

I cant get t to work on android no matter what broswer I use. LastPass works well though, i guess for free cant complain too much.

Which Android version your phone has? Which Chrome version you are using? And which Bitwarden version you use?

You need Android 11 and Chrome 89 at least for it to work. And then you need to enable the feature from Bitwarden.

I seem to have the same issue on Galaxy S10e, Android 11, latest version of Chrome and Gboard.

In the app option for Bitwarden I have now only enabled ‘auto fill service’ and ‘use inline’ autofill. The other 2 are disabled. But I’m not 100% sure if all the rest of the system settings/permissions are correct, and not even how this would be supposed to function if it worked. I don’t get to see anything like the screenshot on the (very minimal) support page mentioned earlier.

My impression is that IME should work and that, then, I can simply have the passwords filled out like the built-in chrome save password function would work? Or see something in the keyboard? Both of which I’m not seeing. Briefly I have also enabled the ‘draw over’ method which seemed to work but always redirects you to the Bitwarden app instead of filling out the login details.

Any assistance would be greatly appreciated.