Can't log in on Android with a correct password

Hi, I get a weird error when trying to log in using BW app on my Android device. Android v8.1.0, Russia; trying to log in fails with a popup that only says “error occurred”(in Russian). I get same exact popup error when I get my Email/Password wrong, but I tested it several times and I’m 100% sure I got them correct, also I have no problems when I log in with my browser. Tried wiping memory/app data, clean reinstall & rebooting device, still no effect. I use strong 3G internet connection when loging in. I am NOT using a VPN. Time on my device is up to date. Creating an account with app works fine, and error starts to appear only some time after that. Sometimes error starts to happen immediately, after creating an account with app, sometimes it takes an hour or so for it start appearing. I didn’t mess with any settings after creating account. I don’t use 2fa or any other extra authentication mechanism. I already tried writing to tech support but couldn’t get a human person to review my report. What can I do to help fix this?

Hi, looks like it’s not only you. I have the same issues, can’t login. Worked ~3/4h fine before. I’m logged in with the browser & app but can’t login with a new browser or desktop app. vault website also not working.

Edit: Just got logged out of my working browser extension and can’t login again.

Edit 2: Looks like only my company network is affected. I’m able to login from home network.

It looks fine over here:
So perhaps contact their support.

Yep, created a case. Issue is fixed now. Not sure what exactly was fixed but it’s working for us again.