Bitwarden loads all username and password

Hello,
I am using bitwarden on chrome extension. On some URLs it loads all the passwords I have in bitwarden. Can someone let me know how can I fix that ?

@Navid_Nosrati Hi!

I’m not exactly sure, what “it loads all the passwords” mean? You mean auto-fill, right? And it fills them in all at once? Or it offers you all passwords? - Please elaborate, what exactly happens, maybe per additional screenshot.

And then some ideas already:

Did you identify e.g. one URL/domain, for which this happens?

Can you check for the vault items, that are shown to you (assuming they are offered to you all as auto-fill entries), that the domain for that that happens, is not listed as an URI for that vault item?


Thanks for kind reply.
This is what bothering me on some urls

Okay, I hope I understand.

Can you please check for at least one wrong entry of the 28 entries in your example, what URIs are stored in there?

You can open a vault entry by clicking on this symbol:

The URIs should look like that:

Is there only the right URI that should be associated to this vault item? Or is there also a URI, that should not be in there? Maybe make a screenshot, but please scramble/blur personal information then.

PS: In other words: I suspect, the vault items that wrongfully show up on domains, have those wrong domains as URIs stored in those vault items.

So probably, if you delete those wrong domains/URIs in those vault items that wrongfully show up on (those) domains, your problem should go away. But you have to go through every one of those vault items and delete the wrong domains/URis there.

There is only the right url

I understand what you mean but I already check that part and there are no wrong urls.

Okay, then at the moment I have no direct clue and you have to provide more information.

For example: what tab do you mean in the browser extension? - Do you have an example URL where it happens? Do the URLs share a kind of pattern?

You don’t have those URLs defined as “equivalent domains” in the web vault, have you?

Did you change something with the URI matching? (in general or in the regarding vault items)

Can you make a screenshot from one - or better two - vault items where it happens for a certain domain (especially URI section)? (of course, again, without containing personal information)

If you can find one of these 28 URLs that is not sensitive information, I would highly recommend that you open that item in Edit mode, and take a screenshot that shows the URI values and the corresponding match detection settings, and post it here.

In addition, please go to Settings > Auto-fill and tell us (or better yet, screenshot) what value has been selected for the option “Default URI match detection”.