Bei Google Anmeldung wird beim Benutzer das Passwort eingetragen

Ich habe die Logindaten für Google auf dem Tablet in Bitwarden gespeichert. Auf der Login-Seite von Google im Chrome kann ich per Bitwarden die gespeicherten Daten eintragen. Leider wird das Passwort beim Benutzernamen eingetragen.

You may have to set up some custom fields. I believe that you will need two custom fields, and it seems that one of the custom fields should be configured as a “linked” field, given the name identifierId, and be linked to your Username.

I don’t have a Google login myself, so I can’t determine what the best setup would be for the second field (to correct the auto-filling of your password). However, the linked instructions explain how to find the custom field name that you would need to use for the password.

Looking at the HTML code, I’m speculating that it may be possible to define a second custom field named hiddenPassword, which would be linked to your Password.

Let us know what happens when you try this.

Danke für die Antwort.
Aktuell bin in ich bei Enpass und erwäge einen Wechsel zu Bitwarden. Doch wenn ich Google als erstes in Bitwarden speichern möchte und es klappt nicht, macht es keinen guten Eindruck.

Ich habe das Forum durchsucht und es scheint dass ich der einzige mit dem Problem bin. Habe sogar den Cache von der Google Chrome App gelöscht. Aber der Login-Fehler bleibt bestehen.

Habe nicht vor irgendwelche speziellen Einstellungen vorzunehmen nur um einen Login zu speichern/verwenden.

Gerade noch einmal ausprobiert: Google Chrome gestartet, Inkognito-Fenster geöffnet, Google.com aufgerufen, auf Anmelden geklickt, Strg+Shift+L gedrückt und die zuletzt für Google.com verwendete eMail-Adresse wurde korrekt eingetragen, auf Weiter geklickt, Strg+Shift+L gedrückt und das dazu passende Kennwort wurde eingetragen. Also alles so, wie es sein soll.

Kämpfen bei Ihnen vielleicht die Enpass-Browser-Erweiterung oder/und der Google-Chrome eigene Kennwort-Manager gegen Bitwarden um die Vorherrschaft ?

Auf dem PC habe ich Bitwarden noch nicht ausprobiert. Mein Problem bezieht sich auf das Tablet mit Android. Alles ist auf dem neuesten Stand auf dem Galaxy Tab S8 Ultra.

Enpass wurde schon der Installation von Bitwarden deinstalliert. Bitwarden ist auch in den Einstellungen auf Autofill gesetzt. Im Chrome ist das Passwort speichern schon seit Jahren deaktiviert. Von daher kann ich eine Störung ausschließen.

Dazu habe ich auch den Tag auf "app:mobil: gesetzt

Ich beobachte dasselbe Problem wie Jochen, bei mir ist es ein Fairphone 4 mit Android 11, Bitwarden App 2022.10.0. Bei genauerem Testen stelle ich fest:

Bei folgenden Browsern wird auf accounts.google.com mit dem Auto-fill Service das Passwort an Stelle der Email-Adresse eingetragen:

  • Brave Browser
  • Google Chrome

Mit folgenden beiden Mobile Browsern klappt es wie gewünscht:

  • Firefox Klar
  • DuckDuck Go

An der Konfiguration des Eintrags in Bitwarden kann es bei mir nicht liegen. Am PC (Firefox und Brave) klappt es prima.

Das Problem besteht in Chrome und auch im Brave Browser. Auch bei CHECK24.de wird das Passwort beim Namen eingetragen.

Hello @Joerg , welcome to the community forum!

I am not sure that this conclusion is valid. Both you and Jochen are reporting problems with auto-fill in an Android operating system. I’m fairly sure that the web browsers in mobile operating systems are served web pages that differ from the web pages served to browsers installed on a PC (because the web server can detect your operating system, and customize the content delivered). Therefore, I think it is possible that an auto-fill configuration (in Bitwarden) that has been proven to work on a PC may still fail to work in an Android environment, if the Android-specific version of the web form uses different identifiers for the form fields.

If this is the case, it may still be possible to solve the problem by defining linked custom fields, as I had suggested in my first response. Although Jochen was not interested in this solution, perhaps you will find it worth trying.

Klar wäre ich an der Lösung interessiert. Es macht für mich nur wenig Sinn fast alle Anmeldungen mit einem benutzerdefinierten Feld zu versehen. Das geht bei mir an einem guten Passwort-Manager vorbei.

Scheint so als wenn sich die Entwickler von Bitwarden auf den Desktop konzentrieren und Android vernachlässigen

So far, you mentioned two web pages where the auto-fill was’t working properly, but it is actually “almost all” logins that are not working for you?

In any case, a bug in Bitwarden’s code (or some incompatibility between Bitwarden and your setup) cannot be ruled out, so it would be helpful (for diagnostic purposes) if you (and/or @Joerg) could attempt some of the suggestions that have been proposed and see if any progress can be made.

Also, can you confirm that Enpass was able to autofill the Google and Check24 login forms correctly (on the same tablet)?

Bisher war ich bei Enpass und prüfe einen Wechsel zu Bitwarden, weshalb ich noch nicht so viele Logins getestet habe. Auf den Tablet ist aber Enpass deinstalliert.
Um das Problem einzugrenzen habe ich Bitwarden auch auf meinem Smartphone Huawei P30 Pro installiert. Dort verwende ich den Brave Browser . Auch hier kann ich die gleichen Login-Fehler von Bitwarden feststellen.

Inzwischen habe ich einige Tests zu Passwort-Manager gelesen. Oft wird die Unzuverlässigkeit von Bitwarden beim automatischen eintragen der Login-Daten bemängelt.

Somit schließe ich einen Setup-Fehler von mir aus

I don’t think anybody was suggesting user error as the cause of your problems.

Some web forms are coded in a way that makes it practically impossible for any password manager to recognize the login fields correctly; in some (but not all) such cases, the problem can be solved by defining custom fields. This is why I was interested in whether Enpass was able to correctly complete the auto-fill on these websites. Although the test would be more conclusive if done on the same device that was causing problems for Bitwarden, it would still help if you can do the test with Enpass using Chrome or Brave in an Android operating system.

Finally, to reiterate what I said above, we don’t have enough information at this point to determine the cause of the problem. It is entirely possible that some bug has been introduced in the code base for the Android app.

Enpass hatte in der Vergangenheit immer problemlos die Logins auf meinem Galaxy Tab S8 Ultra und Huawei P30 Pro ausgefüllt. Trotzdem erwäge ich einen Wechsel auf Bitwarden.

Auf beiden Geräten habe ich Enpass deinstalliert und Bitwarden mit Autofill installiert. Seitdem habe ich Login Probleme bzw. wird beim Benutzernamen das Passwort eingetragen. Alle Geräte haben immer die neuesten Updates installiert

Also besteht das Problem auf den gleichen Geräten.

@1001Musik Jochen, I think that this response of yours may have been posted in the wrong forum topic:

Perhaps one of the mods can move it (paging @dh024 or @dwbit for help with this).

Your experience is definitely not typical, which is why I was attempting to see if a cause for the problem could be identified. If it is a bug in Bitwarden, and if it can be reproduced by others, then it should be reported on GitHub. Actually, there are a few issues similar to yours already reported there (Issue #1339; Issue #1388). There is also a general discussion of autofill problems in the mobile apps in Issue #1389, in which Bitwarden provides a form for reporting problems with specific websites, so that they can track the issue and work on strategies for fixing these problems.

Hey @1001Musik you can also contact our support team directly at bitwarden.com/contact