What happened with Bitwarden Desktop and MacOs High Sierra?

What’s going on ? the desktop application updates automatically, then does not launch anymore since it is Mojave compatible at the minimum.
Back to 1Password, I hope not…


See this thread for a recent discussion of this issue:

1 Like

Exactly the same… have to stop some process to connect BitWarden and avoid updating… But it’s really frustrating (and may be not safe…?..)

1Password 7 requires macOS High Sierra 10.13 or later.

Based on 1Password’ss history, soon, new versions will also stop working on High Sierra.
Being proprietary software it is doubtful that future versions of 1password will work with older macos version.

Keepass XC seems to be the best alternative cross platform option, but that requires a higher level of knowledge to get working with cloud syncing etc.

KeepassXC precompiled binary is ALSO currently for MacOS 10.13+ but maybe installing via “brew” may allow it to run on 10.12.

Another option might be to self-host an older version of Bitwarden, but that is beyond most people’s technical skill and can open you to future security risks.

My current solution is to no longer use the desktop version, and just use the browser plugin, and phone apps.

If your device does not allow you to run the latest version, you can find previous releases here.

I am running Mac 10.13.6 High Sierra on an old iMac, cannot migrate to a newer version. Bitwarden did an automatic update then refused to start because it needs a newer version of the Mac OS.
I used timemachine to remove the update (back to 1.31.3) but now I get the message that I need to restart to install the update/complete the installation of 1.32 (I think).

I want to disable the update. I have seen messages about “environment variable ELECTRON_NO_UPDATER=1” but I have no idea where to set this, please can someone explain this in more detail?

Will I get problems in the future if the version updates on my iDevices and my Linux laptop, but it does not on my Mac?

See this other topic:

Can anyone recommend a password manage that WILL work on High Sierra

Out of curiosity, did you try the instructions I posted above??

I will do, but if this is not supported I’d rather try to find something that is.

also will there be problems if i have updated on ipad and linux but not on mac?

I tried what you suggested, but I still get the update message. I keep clicking ‘later’ but I will have to restart the computer sometime. I just tried using time machine again and the backed up version when started still gives the update message. I am at my wits end, and feel I am being forced into either abandoning Bitwarden or spending a considerable sum on getting a new computer, when this one works perfectly well for everything except Bitwarden. I feel so upset about this as I have really liked using Bitwarden, it has made life so much easier up until now.

Hi @gabriellestanley, we are tracking the issue on Github here. In the meantime, have you installed the Bitwarden browser extension, or visited the web vault?

Yes to both of these.

Strangely, even though I used time machine to go back to a previous version of Bitwarden, when I use ‘about’ it tells me I am using 1.32.1 and I am not aware of updating - but it seems to work on High Sierra. So at least it seems at the moment that i do not have to worry about the update this time. (It would have been nice to find out this without all the worry about being without access to my passwords.)