OS X 13.6 and update to 1.32 rollback issue

I am using OS X 10.13.6 with Bitwarden V 1.31.3 and the app requested I upgrade to 1.32. I upgraded only to find out that I require OS X 10.14 which I cannot install on my old computer. I uninstalled the app and cleared the caches and preferences and thru the assets downloaded v 1.31.3 . I can install and use Bitwarden 1.31.3 once then when I restart the app it says I need OS X 10.14 again. Is there something I’m not clearing? or is the default of Bitwarden forcing me to upgrade to 10.14 which I cannot



Similar issue. Also using macOS High Sierra 10.13.6. Installed update to Bitwarden 1.32.0. Won’t launch because it requires 10.14 which I also cannot install on my old iMac. Uninstalled the app, re-downloaded 1.31.3, upon launching Bitwarden the window briefly appears then the app crashes.

How can I get Bitwarden working again?

I finally got Bitwarden working again. Reinstalled Bitwarden app version 1.31.2 from backup. It’s working again for me. Problem is Bitwarden auto updates to version 1.32.0 upon quitting the app then upon next launch it says “You can’t use this version of the application “Bitwarden” with this version of macOS. You have macOS 10.13.6. The application requires macOS 10.14 or later.”

Unfortunately, Mac OS versions prior to 10.14 are no longer supported by Bitwarden, as they suggest there are compatibility issues with the current version of the server that can’t be resolved for legacy operating systems.

If you are finding that version 1.31 of the desktop app is working for you, there was a thread from a while ago that suggested you can disable the auto-update feature, but obviously this is a less-than-ideal solution:


How does one set the ELECTRON_NO_UPDATER=1 variable?

Open a Terminal window in your Mac (Applications > Utilities > Terminal) and set your environment variables by entering this line of code and pressing the RETURN key:

echo “export ELECTRON_NO_UPDATER=1” >> ~/.bash_profile

Reboot your mac and it SHOULD work (this thread is a bit old, so no guarantees).


Thank you for your help on this

1 Like

Thank you. Do you know by any chance if this can disable auto-updates of all Electro apps? Or is it just Bitwarden app?

I wish I can just disable Electron apps update because they are nagging me all the time and with some apps they keep pushing updates every few days without seeing any meaningful changes in the non-life-essential apps.

1 Like

That’s a very good question, @itoldusoandso. I assume it will disable auto-update on all Electron apps that you access on the mac, given that it is an OS-level option.

1 Like

I cant see this being the case for something as simple as a client app. Especially when the code is also running on some linux releases and win 10 which are older than MacOS 10.13 for example.

I have seen this issue before for other macos software, and it was simply a matter of not wanting to compile 2 versions with xcode. Not sure if this is the case here. Maybe someone can compile it themselves and see.

It is especially problematic because Apple limits how long you can run MacOS on a mac. While this happens with other devices, Apple does it over a shorter period, with the goal of forcing people to buy new Apple hardware.

This normally isn’t a huge problem, until the software that you are running on the device starts to be compiled in a way that also limits which MacOS version can be used, even though the underlying OS is still fully capable of running the code.

FWIW: 1.31 to 1.32 changelog only shows “Introduce captcha upon 5 failed login attempts”

This works for me on MacOS 10.13 as of today

I strongly disagree. Any corporate environment doesn’t want individual apps to auto update specifically for security and stability reasons.

As has already been posted here, having installs automatically update can lead to fully compromised systems, as was the case with passwordstate’s update servers being hacked, and ALL passwords being compromised.

To autoupdate or not, should be easily disabled.

Setting the environment variable prevents updates from be downloaded.

If your system has already downloaded the 1.32 update, you will need to delete it, otherwise Bitwarden Deskop will keep asking to install it.

The downloaded update is located:
/Users//Library/Application Support/Caches/bitwarden-updater/pending/

Here I managed to make the auto update stop, changing the permission of the folder where the updates are performed, as read-only. The folder has already been posted here in the post:

/Users//Library/Application Support/Caches/bitwarden-updater/pending/

Added: Remembering that you must clear the contents of the update folder, otherwise the update will still be done.


Well, whoop-de-do, I tried this and I’m still getting an update message. I clicker ‘later’ but who knows what will happen when I next reboot. (Which doesn’t happen everyday because of the time needed to restart DropBox, which slows everything else down.)

The 1.32.1 update fixed my issue.

Bitwarden version 1.32.1 is working on my iMac running 10.13.6. Can you delete 1.32 then redownload 1.32.1 from the App Store?

I did that, but now mine doesn’t finish loading. I will try to clean all traces of the old installation and try again.

1 Like

Sorry, this is old post a bit, just wondering, are you saying 1.32.1 is working or are you saying 1.32.1 is working AND it doesn’t give the auto-update nags?

I am on 10.13 Sierra and I running 1.33 and it works fine but I do get the auto-udpdate nags. Tried all possible fixes and it works for a while but at some point of time to fixes get unfixed and need to apply them again.

I am using ver 2022.5.1 and it seems to have solved the problem. You can go to github to download the asset

My Bitwarden version 1.32.1 auto updated to version 2022.5.1 and is still working fine on my old iMac running High Sierra 10.13.6. No auto-update nags, whew! Version 1.32.1 also had no auto-update nags.