[ Solved] U2F in Chrome


I just upgraded to premium and tried to add an U2F Key to my self hosted bitwarden installation.

Adding the key and also logging in with Firefox (and U2F enabled) worked without a problem.

But when trying to login with Chrome 72 I receive a red “U2F Error: 2”.

Using Chrome with other U2F logins on other site works.

Could you give me hint what is going wrong?

In the console I see the following error:

Failed to load resource: the server responded with a status of 400 (Bad Request)

I found the problem.

I changed my domain name for my self hosted installation und there was a wrong host name in the web/app-id.json. Still wondering why Firefox accepts this.

I saw the same problem with bitwarden_rw 2.11.0 on a self-hosted installation:
Within the docker-container, there’s a file /web-vault/app-id.json:
[email protected]:/web-vault# cat /web-vault/app-id.json
“trustedFacets”: [
“version”: {
“major”: 1,
“minor”: 0
“ids”: [

I had to modify the url and used
sed -i -e ‘s/vault.bitwarden.com/bitwarden.myhost.com/g’ /web-vault/app-id.json

I should have read the instructions better, especially point 9 on modifying app-id.json.