Master password re-prompt not working after unlocking the vault with Windows Hello

Windows client 2023.08.04, observed since some time (maybe 2-3 releases back).

Problem occurs for items protected by “Master password re-prompt” feature. When prompted for the first time after launching and unlocking the vault, all is fine, meaning after providing proper master password all works ass supposed (protected item, i.e password, is copied to the clipboard). However after locking the vault and then unlocking it with Windows Hello (PIN), when the Bitwarden client prompts for master password re-prompt it is impossible to provide it. You can type it, but pressing ENTER or OK button is not working any more.

To reproduce:

  1. Have freshy open Bitwarden client with unlocked vault
  2. Open some “Master password re-prompt” protected item
  3. Provide the master password to copy the protected entry (i.e. password)
  4. Lock the vault (or wait for auto-lock)
  5. Unlock it with Windows Hello (PIN)
  6. Go to the same item and try to copy its password
  7. Master password confirmation window will open. You still can type the master password, but you cannot really submit it (pressing ENTER or OK button will not work)

Additional info:
I have my Bitwarden self hosted, but as it seems to be client related issue it may apply to cloud based too.
I do not know it it matters, but my client minimizes to Windows tray when locked or window closed.

same thing here - been happening for a while only in extension and I would use windows client but now I’m experiencing this also in windows client - 2023.8.4 - password protected entryh and when I punch in the master password - the OK doesn’t work!

Same problem here. I’m self-hosted and experience it with the extension. I’m using VaultWarden in a Docker container and perhaps that needs to be updated. It didn’t start until recently.

Updated VaultWarden, no change in behavior. Interestingly there is no Re-prompt for master password setting in BitWarden anymore! Hmmm… Works in Chrome and Firefox but not in Brave. Perhaps I need to reinstall the extension or restart Brave?

OK reinstalling extension fixed it for me.

Vaultwarden is not a Bitwarden product, and from time to time there will be incompatibilities between Vaultwarden server software and the official Bitwarden client apps/extensions. If you encounter any issues in the future, please reach out to the Vaultwarden community for assistance:

The problem doesn’t seem to be with VaultWarden. Indeed FF and Chrome worked find even without updating Vaultwarden.