Keyboard Shortcut (SHIFT+CMD+L) fails intermittently

I would assume the same, but if there’s a conflict between Bitwarden and Safari keyboard shortcuts, even an unseen one, that may be why it works temporarily and then stops?

The potential conflict with the default shortcut with the Safari sidebar always existed, but it seems like shortcuts set by extensions get preference.

If you turn off Bitwarden, Cmd+Shift+L opens the Safari sidebar. When the BW shortcut fails like described in this thread, Cmd+Shift+L does nothing.

Since the problem also affects the red badge counter, there is probably a bigger issue.

1 Like

same issue here - using a M1 MacBook Pro too. Thats really really annoying - does not seem like changing other shortcuts is helping either.

Same issue here. I’m on Intel MacBook Pro 2018.

Started after Mac OS 12.3 and I’m currently on Mac OS 12.3.1 and Safari 15.4 (17613.

No badge and keyboard shortcut not working in Safari. The keyboard shortcut does work in Chrome 100.0.4896.60 and in Firefox 99.0.

Well, here’s something: I’ve found that SHIFT+CMD+Y works. I stumbled across it after misremembering the “Show History” shortcut :rofl:

Not sure if that command always worked, but it’s worth noting perhaps.

Hi @atothek - welcome to the community forums!

If you see no BW badge, then you may be experiencing another issue. Can you confirm which version of the BW app/Safari extension you are using? You definitely want to be using the latest version from the app store (currently 1.32.1/1.57.0).

If that is the case, you can try this to see if it fixes things for you:

  • Close Safari
  • Run the following command in the mac Terminal app:
    /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user
  • Open Safari and hopefully the BW badge is now visible

I’m on 1.57.0 and I’ll try those fixes and report back. Thanks!

1 Like

Ran that command you posted with Safari closed.

Keyboard shortcut worked one time partially (selected first password fine but would not scroll to second upon second press of Cmd-Shift-L).

Then second tab different website keyboard shortcut not working at all.

Badge went away after very first website attempt also.

Clicking the icon to enter the password works fine BTW.

Just chiming in: same problem here:
Macbook M1
Monterey 12.3
Safari 15.4 (17613.
Bitwarden 1.32.1 (2467)

Problem is relatively recent (a few weeks) before that everything is fine. No known shortcut conflicts or anything that could have caused them.

1 Like

Same problem for me too
intel iMac late 2015
Monterey 12.3.1
safari 15.4
bitwarden 1.32.1

Nomterey 12.3.2
MacBook Pro mid-2015
Safari 15.4
Bitwarden 1.33.0

Works well if the Safari Open/Close sidebar keyboard shortcuts (shift + cmd + L) assigned to different ones (e.g. shift + cmd + O).

1 Like

I set the sidebar shortcut to Shift+CTRL+L long ago and am still having issues getting BitWarden’s shortcut to work reliably.

Thanks for feedback everyone, the team is aware of the issue and looking into a resolution. :+1:


I’m sure you guys are really busy, but is there any way to get updates on this? I didn’t realize that so many people were having the same issues and I’m so happy that you’re working on it now and can’t wait for the fix. It’s been driving me nuts.

I experience the same problem on an Intel-based Mac mini 2018

macOS Monterey 12.4
Safari 15.5
Bitwarden 1.58.0

It’s been like that for several weeks, made me actually go back to Firefox on the desktop, sigh.

Here’s how it looks on my end.

Launch Safari, Bitwarden is locked.
Go to a website where I have a login, like this forum. Open the login form.
Press cmd+shift+l, the Bitwarden login prompt is displayed. Enter the credentials, hit Enter.
The login form is filled, the Bitwarden extension is now unlocked and shows a badge.
Sign in to the website. Now the Bitwarden extension is unlocked but the badge has disappeared. The keyboard shortcut no longer works on any website.

Thanks for the feedback @DarkStar, we’re tracking this issue here: Keyboard Shortcut (SHIFT+CMD+L) fails intermittently · Issue #2475 · bitwarden/clients · GitHub