Safari: Keyboard Shortcut not Working

Hello, I have an intermittent problem with Safari 15 on MacOS 12. Most of the time I cannot get the Cmd + Shift + L to work with auto fill. Even if I restart Safari, the problem persists. Any known info for this?

Thanks in advance!

It could be that this keyboard shortcut combination has been mapped to something else.

You can check by opening System Preferences → Keyboard → Shortcuts → Services or App Shortcuts.

For example, under the Services dialog, Shift-Command-L was mapped to Search With Google on my MacBook, which I believe is a default system setting (just disable it). Check in the App Shortcuts dialog, also, in case there are any conflicting entries there. Alternatively, you can map a new shortcut for Bitwarden in the App Shortcuts dialog, if you like (e.g., Option-Command-L).

Hope that helps. Cheers!

Thank you

Looks like mine had the same “Search with Google” option set. I disabled it and had to reboot the system to get it working with Auto-fill again. I’ll have to see if it stays working. I know with Safari 15, Cmd + Shift + L is a default shortcut to open the sidebar too, so hopefully that isn’t conflicting.

I came across this because I also have intermittent issues with Shift-Command-L not working. I disabled the system shortcut as suggested by David H but nothing changed for me. However, I discovered something which may be a bug.

If I do the following, the keyboard shortcut stops working until I quit Safari and restart.

  1. Open Safari and DO NOT unlock my vault
  2. Go to a login page that I can fill from my vault
  3. Hit Shift-Cmd-L
  4. Enter my master password in the new tab that bw just opened
    At this point, bitwarden fills in the fields on my login page but the shortcut key has now stopped working forever, until I restart the browser.

If I do the following, the the shortcut works and continues to do so.

  1. Open safari and unlock my vault before visiting a login page that needs it
  2. Go to a login page that I can fill from my vault
  3. Hit Shift-Cmd-L
    At this point, the form gets filled out and the shortcut continues to work in the future.
1 Like

I’m seeing the same issue as Carl. Been like this for a few weeks.

There is a similar discussion here:

Many people (including me) see this problem on M1-based Macs after updating to macOS 12.3.

1 Like

I have an Intel based Mac and have the same problem.

The solution appears to be to unlock the browser extension before you try and use the keyboard shortcut, at least for me.

I’m experiencing similar issues. When I disable the extension, I can toggle the Safari sidebar with Cmd+Shift+L. When I enable the extension, I can use the shortcut just once with Bitwarden. After that the shortcut doesn’t react at all. Not to any of both.

I think this is a bug. BW for Safari should select a different keyboard shortcut (Cmd+\ for example?) or make it user configurable.