Bitwarden and local hostnames

When using the Bitwarden app with Samsung Internet, it has troubles with local hostnames and IP addresses.

It does not recognize them correctly. The name of the site will show up as “–” when adding them, and although it shows the right URI in the website field, it will not match them.

The workaround is to visit the sites by IP address instead, but it is still buggy as it does not match on portnumbers, no matter what matching setting you pick.

Will this ever be fixed?

Curious what you mean when you say “local hostnames” specifically.
I have my home which has local machines I can access and say the URI for in Bitwarden but these have a proper .com TLD

I also have another older site though that still uses a .local domain meaning all devices within the domain give a URI of *.domain.local
I can still use either the full FQDN or the hostname to match within Bitwarden.
i.e Server1.example.local will also map to and is accessible by just https://Server1

If you have a port that needs to be accessed, such as I have a machine that host two web-services this can be done with the default match detection of Host
i.e when going to https://Server1:8080 I will get the login for this webpage, but when going to https://Server1:8443 Bitwarden only shows me the relevant login for this other service on the same local machine.

I ment bare hostnames without any “.local” suffix behind it, but just “servername”.

Are you also using Samsung Internet? Because on the desktop I dont have this problems. And there are many people who also encountered it, for example:

and

1 Like

Ahhh I see thanks for providing this detail, I missed the part about Samsung internet.
I do not use this daily hence why I have never encountered this issue. I use separate mobile browsers for personal and work profiles on my phone.

Just tried it out and got the same error, even when searching for the entry and selecting Auto-fill and Save this only populates the hostname in the URI for the entry but does not auto-fill properly.

Edit: As you mentioned desktop functionality works just fine.
It appears other mobile browsers do to, so not sure where the breakage is between Bitwarden and Samsung internet.

Domain name resolution is an operating system function, and Bitwarden can’t control this. Android has had a long history of issues resolving .local domains, so I am not sure what Bitwarden can do about this. For example, see

https://issuetracker.google.com/issues/140786115

URI matching on IP and port works for me on Android. Are you using the “Starts With” matching scheme? The format is like my example below:

https://192.168.1.100:9090

Hi David,

The issue you mentioned is about resolving local domains, that is something totally different then Bitwarden not being able to match them.

I am not able to match the URL’s as in your example, not with the “Starts With” or any other scheme. Are you sure you are using Samsung Internet, because this bug is specific to it.

I’m sure the root cause for the issue is on Samsungs side. But as this problem existed for so long, it would be nice if Bitwarden made some workaround in the code to be able to handle this (faulty) behaviour, even though it’s not their fault.

Sorry if I misunderstood. But you are right - it does seem like an issue with the Samsung Internet app. I can actually use network apps on my Android device to ping other machines on my home network using a .local domain, but Samsung Internet doesn’t seem to recognize the .local domain name.

And I see that Samsung Internet will forward you to an IP#:port address just fine, but it does not retain the port number once connected, and it refuses to pass this along to the Bitwarden client to save it. It is almost like some strange internal permanent redirect. Thus, even if you enter all the correct matching manually, for all intents and purposes Samsung Internet sees https://192.168.1.100:9090 as just https://192.168.1.100, meaning Bitwarden can’t match on URLs that include port #s. Wierd issue as Firefox and Chrome have no problem with this, and the matching works perfectly.

2 Likes