[Solved] Safari extension lost after upgrade to 1.25

Background: macOS Big Sur v11.2.3

Bitwarden prompted me to upgrade to a new version - 1.25 . I allowed it to upgrade. After upgrade I have lost the Safari extension for Bitwarden. I have re-installed the Bitwarden application by downloading instead of auto-update. Restarted the computer twice. Restarted Safari. Nothing has restored the Safari extension.

If I open the Safari extensions page, it does not list Bitwarden as an available extension.

I use the extension all the time and was working without issue prior to upgrading to Bitwarden v1.25.

Any thoughts on how to restore the extension in Safari?

Found the solution:

https://bitwarden.com/help/article/install-safari-app-extension/

Pay attention to the newly added note regarding the 2021-03-11 release. Bitwarden really should have added this warning to the to upgrade notification. The message needs to be far more obvious. Many Mac customers are going to be caught out by this.

The Safari extension is no longer available via the .dmg installer. You must install via the Apple Mac AppStore.

2 Likes

Not [Solved] at all. Installing Bitwarden via Homebrew has been rendered completely useless.

Curious why it has been rendered useless?

I use brew myself too but not for the Bitwarden desktop app, only the CLI. The reason why the Safari extension can only be installed via the Mac AppStore is due to an Apple constraint, not a choice Bitwarden have made. So wouldn’t the Brew installs still work except for the Safari extension?

You’re mistaken, the extension worked just fine with the Brew installation, until the last update.

I never said it didn’t work with a Brew installation.

What I do seem to be mistaken about after doing some research, is that Apple still support Safari App Extensions. Safari Web Extensions seem to be their preferred approach for the future but I don’t see any EOL date for App Extensions. So I don’t know why Bitwarden have forced the issue by dropping support for their App Extension.

Not [solved], not working. I have now: removed bitwarden. Reinstalled bitwarden from the app store. Opened bitwarden (for the first time since installing from the app store). Open safari, go to preferences, go to “Extensions” tab: no bitwarden extension. Then, repeated these steps in various ways, including restarts of Macbook in between. No bitwarden extension to be found anywhere. I’m on Catalina, 10.15.6. What do I do next? Install Big Sur?

1 Like

I have the same problem. I am on Catalina (can’t upgrade to Big Sur as it’s a company managed Mac), and after the upgrade to Bitwarden 1.25.0 I lost the Safari extension. I removed Bitwarden and installed it through the App store: same story, extension missing from the list of available ones.
Is the extension only compatible with Safari 14+?
In that case, we Catalina users won’t be able to use it, I guess?

1 Like

I suggest you both raise a support request to ensure Bitwarden are aware of the issue:

1 Like

Thanks, I dropped them an email, and included a link to this thread.

I’ve got a reply from the team, basically the Safari extension for Bitwarden 2.50 won’t work with Safari 13 (it’s only compatible with Safari 14+). I copy and paste their workaround which implies downloading a previous version of Bitwarden, and disabling auto-updates

​As for the Safari 13 issue: our newest release of Safari Extension can only be used on Safari 14+: Release Notes | Bitwarden Help & Support

If you are still using an older version of Safari you shouldn’t upgrade to our latest version. But, if you have upgraded already, in order to install an older version, you can download the file from here: https://github.com/bitwarden/desktop/releases/download/v1.24.6/Bitwarden-1.24.6.dmg

Then, in order to prevent for the app to auto-update, you need to open a Terminal in your Mac (Applications > Utilities > Terminal) and set your environment variables with this step: echo “export ELECTRON_NO_UPDATER=1” >> ~/.bash_profile

2 Likes

Safari 14 is available for Catalina based on the info I’ve found googling.

Thanks very much. This solved the problem for me. I’m using Safari 13.1.2

I’m having the same issue. Just opened another support ticket. I’m on Big Sur 11.2.3.

Having the same issue since going to 1.25.

Reading the article about 1.25 needed to be added from the Mac App Store instead of via .dmg, I removed the app, re-installed it, and the Safari extension is still not showing up.

BW:Version 1.25.0 (516)
Safari: Version 14.0.3 (16610.4.3.1.7)
macOS Version 11.2.3 (20D91)

I’m having the same issue with the extension not showing. However, I’m on Big Sur 11.2.3 and Safari 14.0.3. Bitwarden is installed via AppStore.

I just submitted ticket to their GitHub if you wanna piggy back on that also: Bitwarden 1.25.0 Extension not showing in Safari 14.0.3 on macOS 11.2.3 · Issue #1718 · bitwarden/browser · GitHub

1 Like

Ooops. Spoke too soon. The extension has disappeared again and this time I can’t get it back! This is a real pain as up until now Bitwarden has been brilliant and I’ve used it all the time. Without the extension button it’s not very user friendly any more so I’ll be using it a lot less. As a paying member, I hope it can get sorted again soon.

Can someone properly explain to me how this works? This doesn’t seem to do anything.

I wonder if part of the reason Safari 13 reverts and I lose the Bitwarden extension (like everyone else) is because the program is actually still updating itself. I have tried below, but it definitely doesn’t stop Bitwarden from immediately updating as soon as I attempt to open 1.24. Where do I have to paste this in Terminal? (In which folder?) and do I have to substitute something for “bash_profile” or something? Basically, what am I missing?

Thank you!

Then, in order to prevent for the app to auto-update, you need to open a Terminal in your Mac (Applications > Utilities > Terminal) and set your environment variables with this step: echo “export ELECTRON_NO_UPDATER=1” >> ~/.bash_profile

For those with Safari 13 and lower, please try this release: