[Solved] Safari extension lost after upgrade to 1.25

Yessss, that got my extension back! Thanks, I’ll stick with this version for now…

I’ve been having the same problem with the Bitwarden extension disappearing in Safari 14 (14.03) - and yes I’d been around the loop of removing Bitwarden, making sure it was downloaded from the App Store, rebooting, etc etc - Safari wasn’t showing the extension as even being installed or available no matter what I did.
So I downloaded the Safari Technology Preview (which is basically a fresh install of Safari Safari Technology Preview - Safari - Apple Developer) - and it immediately spots the Bitwarden extension and allows you to add it. If you then open up ‘normal’ Safari it has then been triggered into spotting the Bitwarden extension again and works fine. You can then just remove the Safari Technology Preview.

I would guess (but haven’t tried) that just uninstalling and re-installing Safari would do the trick - but to be honest that felt a bit drastic.


Thank you @Culfri works for me, too!

1 Like

@Culfri, same here. Your solution fixed this for me. Thanks so much!

I am on Catalina 10.15.7 and Safari 14.0.3. I quite likely was using the older version of Bitwarden. Safari then needed to be updated or upgraded. Bitwarden Safari extension stopped working. I deleted all Bitwarden files, reboot and reinstalled using AppStore version. Went to Safari-Preferences-Extensions. No Bitwarden Extension!!!

I guess I am stuck with it by manually copy and paste the needful which is a pity until Bitwarden resolves this issue.

Thank you @Culfri works for me. I guess you might be right that the same results might work by uninstalling and reinstalling Safari. I am happy it is working now. So let it lay to rest for a bit till Bitwarden permanently address this problem.

thanks!! works fine now

hello i seem to have lost my Safari extension. Im still on BW 1.24.7 (frozen) and Safari 13.1.3. but my extension is gone this morning?? Any ideas what i can do to get it back. It was working flawlessly for a couple of months.


Why don’t you read first? The solution to your problem is mentioned and confirmed several times within this topic.

Seems i was able to restore the Safari extension by reinstalling the BW frozen version mentioned above.

1 Like