[SOLVED] Bitwarden Android app not asking for 2FA key

I have a BW premium account secured with Yubikey 5C NFC, both for FIDO2 WebAuth and for OTP (besides Twilio Authy for TOTP).

It works fine in the browser (Firefox) but it does not ask for 2FA (of any kind) on my Android 10 Smartphone (with NFC).

I checked the “One of my keys supports NFC” in the 2FA section of the web vault. I completely log out and re-entered the Android app.

No way: the Android app always enters me straight to the vault after fingerprint recognition or PIN entering, without asking for 2FA key.

Is 2FA not supported on phones?

Any suggestion?

You can also deauthorize previously trusted devices by going to your web vault, then access Deauthorize Sessions from the Settings menu. Then you will always be prompted for 2FA, unless you indicate to remember the device again.

https://bitwarden.com/help/article/twostep-faqs/#q-why-is-bitwarden-not-asking-for-my-enabled-two-step-login-method

2 Likes

It worked. Thanks.

2 Likes

You said “it worked” but you didn’t say what “it” was. Can you edit your original post to make it clear what you did that worked? Thanks.

1 Like