SMTP verification email (Gmail)


#1

Hello all,

I made a fresh install a few hours ago and I’m trying to verify my new user but it seems that something is not working. My current setup inside ./bwdata/env/global.override.env is:

[email protected]
globalSettings__mail__smtp__host=smtp.gmail.com
globalSettings__mail__smtp__username=MyAccount
globalSettings__mail__smtp__password=MyPassword
globalSettings__mail__smtp__ssl=true
globalSettings__mail__smtp__port=587
globalSettings__mail__smtp__useDefaultCredentials=false
globalSettings__disableUserRegistration=true

./bwdata/logs/api/Api/date-filename.log file ouputs this:

2018-09-10 21:48:30.928 +00:00 [Error] Mail send failed.
System.Net.Mail.SmtpException: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.5.1 Authentication Required. Learn more at
at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)
at System.Net.Mail.MailCommand.EndSend(IAsyncResult result)
at System.Net.Mail.SendMailAsyncResult.SendMailFromCompleted(IAsyncResult result)
— End of stack trace from previous location where exception was thrown —
at System.Net.Mail.SendMailAsyncResult.End(IAsyncResult result)
at System.Net.Mail.SmtpClient.SendMailCallback(IAsyncResult result)

I tried to change the port to 465, disable SSL, a different account…but nothing seems to work.

BTW, I changed “enable insecure apps” option to yes in the Gmail account.

Could someone help me with this?

Thanks!


#2

Did you put in your gmail credentials? And not your bitwarden account credentials. I have tested the same setup with my gmail account and it is working for me.


#3

Hey Bob,

Yep I did it already. I tried more than one gmail account but no luck. I don’t know if something related to ports or something like that may be blocking the outgoing.


#4

Did you ever get this working? I’m having the same problem.


#5

I had problems using my personal email account. It turned out to be a incorrect smtp setting in my global.override.env file. You can test your smtp settings using this website: https://www.smtper.net/
Just input your smtp settings and click on the green button. It will tell you straight away if the test worked. You will also get a test email in your inbox if it worked. If your settings don’t work, try changing the settings and repeat until you find the correct settings.
Once you have your settings, but copy them into your global.override.env file and you’re good to go.
If you can’t get any settings to work, there are plenty of websites that show the correct settings for most email providers.