Verification email and admin portal self-hosted

Good morning everybody,
i have problems with email verification using gmail as a mail provider. i have checked my firewall settings and my bitwarden server can send mail with port 587 and 465, but it doesn’t work. my settings in the global config are fdas

basically i’m using gmail as a smtp server and i’m waiting for the emails in my hotmail account to complete the procedure. I’m also looking for a log that can show me some error but i can’t find it, i searched in the bwdata/core/ but there is no logs folder inside it.

Any help is much appreciated.

Have you tried using a different mail service? Maybe try running an SMTP server and send using port 25. I’d also check the credentials.

hi elliotroy,
i have already checked the gmail credential. is it possible to try with no credential specified in the global config?

little update, even with another smtp server with port 25 doesn’t work. i would like to know where to look for the smtp logs. I’m suspected that my server doesn’t send any email at all

I believe you can check the logs here: ~/bwdata/core/logs/api

You should also be able to specify no credentials https://github.com/bitwarden/core/issues/90

there is no log folder insde bwdata/core. The only logs that i saw were in /bwdata/logs/api/Jobs/xx and there isn’t any smtp error inside those files.

Have you tried a fresh install? Can you also confirm the version you are running on please?

actually this is a fresh install it’s the first time that i try bitwarden. the only thing that doesn’t work is the email. i’m running COREVERSION=“1.20.0” and WEBVERSION=“1.27.0” and the installation method i followed is this one https://help.bitwarden.com/article/install-on-premise/

Do you have two factor authentication on the google account?

no i don’t. i double checked the credentials and they are correct.

You can specify with no credentials, as I am doing it this way although with an internal SMTP relay which has the BitWarden instance whitelisted.

image

i have tried but no mail has passed through my smtp internal server. seems like my bitwarden install doesn’t send any mail in any way. is there something to change in the docker settings maybe?

New Bitwarden on prem user here. I just installed Bitwarden on my Synology NAS. The basics work. I’m not sure yet whether push works, will check that later today. And I still have to configure mail. I have a google account with 2FA. How to configure then? I guess I create an app password in Google and then use that as password?

Thanks!

Update: Yes and I got it working. Now only those damn push notifications.