Selfhostes Bitwarden - Nginx Container SSL Error after updating to 1.45

Dear all,

first of all I wish you had a nice Christmas time and you were abe to relax a bit.

I do have an issue where I cannot find the solution.
I am running self hosted bitwarden, no problems for 1,5 years. Last week I updated to version 1.45.2. After that I was not able to get my loginpage in the browser. After checking some logs I see in the nginx error log following line and the nginx container is restarting:

2021/12/27 20:53:13 [emerg] 1#1: cannot load certificate “/bwdata/ssl/self/hostname/bitwarden.crt”: BIO_new_file() failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen(’/bwdata/ssl/self/hostname/bitwarden.crt’,‘r’) error:2006D080:BIO routines:BIO_new_file:no such file)

The certificate is in this place, there is no symlin to this directory or file. The file is readable by openssl, so this cannot be the issue.
I also copied for testing my certificates to another directory and changed it in the config.yml, restartet bitwarden but same error (of course the new directory is shown in the logs).
I also tried with permissions for the file without any success.

I am running out of ideas or google answers for this problem so I would like to ask. Before I did the update of bitwarden I did also an update of the CentOS 7 machine which is running my bitwarden installation.

Do you have any suggestions or you need further informations?

Thanky you in advance.
Best regards
Hubsi

Note: Your question may already be answered in the Bitwarden Help Center.

Just a reminder - All Enterprise, Teams, Families, and Premium subscribers receive priority support at bitwarden.com/contact :partying_face:

Hi, could this be of interest?

Dear all,
thank you very much for your help.

The suggested solution didn´t worked for me and after hours of trying I just restored my backup.

So my installation is working again, the issue can be solved.

Have a nice day