PIN Unlock in Forefox no longer working in 2023.8.3


this problem popped up after an auto update through Firefox (117.0.1 64 bit) to 2023.8.3 today. The PIN prompt is shown but there is no feedback after entering a PIN (correct or not) whatsoever and the window will never close, let alone unlock the vault. After signing out and signing in again with master password I tried to set a PIN again, but that is not possible either. I can enter one but cannot confirm it and close the dialog. Tested on another machine and it’s the same.


The same thing happened to my firefox extension after the update to 2023.8.3 this evening.
Same on another instance of firefox, installed on Brave as a working backup.

1 Like

similar thing here as well. (Windows 11 with latest updates, Firefox 117.0.1 x64, extension update 2023.8.3)
After the extension update and with the PIN not working, I logged out.
Logging in with the master password worked.
Then I set up the PIN again and at first I thougt it wouldn’t work either, but on second try or so I saw the following: when I enter the PIN and let the window open, it seems that nothing happens. When I close the popup window then I still see the “lock” symbol in the extension symbol, but the unlocking with the PIN worked. After a time, or when using a password, the lock symbol changed into the normal (unlocked) symbol or with the numbers of log-ins on a page.

1 Like

Thanks to everyone both advising of this issue, and those who are actively sharing tips and workarounds! Our team is currently tracking this issue and researching how to best resolve.

1 Like

Welcome to the community @raisinbear - we’re glad to have you and appreciate you bringing this to our attention!

1 Like

Same issue for me on Firefox 102.15.1esr and 2023.8.3.
I tried with logout/login, reinstall the extension, restart Firefox. Not able to setup PIN in any scenario. Seems like the Ok button does not do anything. The second button, Abort(?) (Avbryt, in Swedish), do work as it closes the popup.
I am now back at 2023.7.1 and PIN is working as expected.

Same issue here. Relieved to know it’s not just me.

Logging out of the Firefox extension and logging back in with the master password works okay for me. Desktop app works fine with PIN.

After logging in with the master password, I checked the settings and login with PIN was disabled. So I tried re-enabling it, and after I specify a PIN the extension never continues.

The good news is that I also re-enabled login with biometrics (which was broken in the previous release) and that works again.

1 Like

Now I can confirm, that with my laptop it didn’t work after logging out, log in again with master password and setting up the PIN again. I have the same problem here as described above by others of not being able to set up the PIN at all. (–> Firefox extension)

1 Like

for what its worth, it ALSO doesnt work in the chrome extension. same behavior as firefox. it DOES work in the desktop app from the windows store, although it is possible it hasnt updated yet.

1 Like

not only do i have the same problemS described above, ie cannot unlock with pin, cannot set pin after logging out and back in; i also cannot unlock with my master password. i just had to log out and log back in just to access my vault.

i am using firefox extension. my vault locks at browser restart. i no longer have a pin set.

this would only be a minor inconvenience if i were able to unlock my vault with my master password at least, but it is a Major Inconvenience to have to log out and back in every time my browser is restarted.

so i guess i have to set to log out as timeout action and use never timeout.

1 Like

Same for me. Firefox 117.0.1, BW 2023.8.3, Win11. Cannot login with PIN. After removing and reinstalling extension, cannot set a new PIN.

Happy to know it’s not just me. :slightly_smiling_face:

1 Like

The same after the update to 2023.8.3, i tried to logout first then i login with the master password but i cannot set a new PIN … i went back to firefox 2023.7.1 and the PIN is working again.

1 Like

Installing the extension from the github releases page seems to work.
Someone pointed out on reddit that Mozilla Addons’ xpi file weighs only about 4MB, but the one from Github (and indeed, previous releases on Mozilla Addons) weighs about 8-9 MB.
A botched build must be at fault.

I loaded the 2023.8.3 version from Github releases as a temporary addon and everything seems to be working as it should.

Take a look: Release Browser v2023.8.3 · bitwarden/clients · GitHub


Installing from GitHub releases also works for me. Thanks for the workaround!

1 Like

Still can’t log in Bitwarden on Firefox.

Installing the extension from GitHub works until I close FF, then I have to reinstall the extension.

How can I force the permanent installation of the extension on FF?

I am still not able to log in the FF extension with PIN nor Biometric, password works.
BW extension does ask for the password, nothing else. BW Windows app does ask for PIN/Biometric.
How can I force the extension to ask for PIN ?

@BW Team, this is a very bad situation. Many less informed BW users will switch to a simpler, less secure master password if the situation where they cannot use a PIN continues. Installing the extension from a Github repository is not an option for these users.

This is a time critical issue. With every hour that passes, new potentially vulnerable users are created.


@aidler I think you are 200% right!
I consider doing it myself too.
Or switching back to the Firefox built-in password manager :thinking:, how safe or unsafe would that be?
My personal password is 17 long, has small characters + capitals + numbers + special signs. Perfectly safe but difficult. :joy: Entering it so often makes me type my password fluent by now, I couldn’t a month ago :roll_eyes: In fact, I can’t even type blind !
Of course I want a minimum security for my private PC, thus a difficult password is not for nothing.
However making my PC secured like Fort Knox is not only excessive, it’s completely unnecessary too.


Still no fix??? Where are you Bitwarden, are you asleep floating in the sea?

I am not sure there is a real fix.
Or maybe there is?

As this worked for me, try installing desktop 2023.9.0, Firefox add on 2023.8.3, if needed manual install.