MacOS App Keeps asking for Password once per minute

I use BitWarden desktop version 2024.1.0 (18112) on macOS 14.2.1. It had been working great until a recent update. Now it is repeatedly asking to for the password every 1 minute, like it’s on some kind of timer. Even with the vault timeout set to 15 minutes, it still asks for the password every 1 minute. It’s set to lock on timeout.

The thing is, I don’t care if it times out and locks. But the prompt every 1 minute is very annoying.

This does not happen if the desktop app is minimized to the dock, only when the app is maximized (either foreground or background).

Any ideas how to fix this? Restarting the app and rebooting my mac have not helped.

Thanks!

Hi @SizzlerWA, Do you mean that you normally unlock Bitwarden with Touch ID, but this no longer works as intended?

To be able to use Touch ID in Bitwarden, the desktop app stores a secret in Keychain Access.

You could try disabling Touch ID in the Bitwarden app and removing the secret in Keychain Access called “Bitwarden_biometric”. Then start Bitwarden again. If you still experience problems after these steps, I would try reinstalling the app or contact the support.

I’m experiencing what sounds like a similar issue. I normally keep the bitwarden desktop app (on OSX) hidden with the “Minimize to menu bar” option. The problem is that it keeps randomly prompting for touch-unlock, causing a popup which is very disruptive. I want the app to prompt only when I click to focus it and bring it to foreground. Sometimes it prompts multiple times even after pressing “cancel” in the popup which is very annoying. It actually happened while typing this message – I’ve attached an image showing the resulting disruptive state.

I love bitwarden, thanks for the amazing password manager! Unfortunately this new behavior is very hard to live with.

Update: There is another report of this behavior, also from 20 Jan 2024 at: Bitwarden Broken on macOS - keeps requesting password

Update: Strangely, this behavior (request for password every minute) seems to have stopped for me as of this morning.

I did open the preferences today: I changed the vault timeout to 1 minute (I didn’t notice its previous setting). I don’t think I changed any other preferences.

@SizzlerWA @evnp Have you seen a change to this behavior? Thanks.

PS My Bitwarden is now version 2024.2.0… Could that be a difference? Thanks again