iOS App crashing on self-hosting with iOS Beta?

Is anyone running iOS 15 (Beta) with a self-hosted Bitwarden install? In my case the app crashes all the time. When uninstalling and connecting to Bitwarden directly, I have no issue.

How can I troubleshoot this?

4 Likes

Just started using the public beta of iOS 15 myself. Cloud hosted and same issue, noticeably with autofill. Offloading the app and reinstalling will fix it for one use, then back to crashing.

It’s doing the same on non self-hosted as well so we are all in same boat.

here’s the issue report on github https://github.com/bitwarden/mobile/issues/1493

1 Like

I reported this to them shortly after the last beta was released.
Unfortunately they didn’t seem all that interested.
More or less told me I shouldn’t use beta’s :confused:

FYI, Auto-fill is broken as well.
Both seem to work after a reboot for an unpredictable duration and then they stop working.
Usually both though recently I was able to manually load the app and copy/paste a PA that safari wouldn’t auto-fill

Same issue here:
Latest iOS beta.
Not self hosted.
Crashes after one use, reinstall or phone restart allows one use before crashing again.

We’re looking into it, don’t worry :slight_smile:

Always good to get these out of the way during Beta and not post-launch :+1:

3 Likes

I suppose Bitwarden does not open Testflight versions (similar to Signal etc)?

1 Like

Not currently, we just do beta builds for Android at the moment.

[edit: @magicdude4eva worth a feature request, IMO]

1 Like

Beta 6 = Still crashing and still not populating data in apps.
Still broken and getting pretty annoying

1 Like

Can confirm. It is still broken in iOS 15 Beta 6. Because of this, I have to use another password manager :frowning:

Starting happening to me as well. Running iOS 15 Beta 5.
Cannot open the app / use autofill.

A public test flight link is forthcoming :sunglasses:

4 Likes

For me, reinstalling fixed it. I then enabled face id login and autofill, then it broke. I am using iOS 15 beta 6.
I would love to be part of the test flight, see you then.

So what you meant is;
For me, reinstating it DIDN’T fix it

I get what he means - it crashes because of Face ID or autofill. I think that could be helpful.

1 Like

I don’t think that’s conclusive in the least. It just works sometimes and doesn’t others.
I’ve had Face ID on the entire time. If I restart my phone, it works every time. Then the next Tim I try to use it it may or may not. Usually, if it’s not working with safari/browsers then it’s not working independently either. However, there has been instances in which I was unable To use it in safari but was able to exit safari, open BitWarden app and copy the credentials from there to log into a website

You would be correct!

I just did a few tests. On my device, either reinstalling the app or restarting my phone allows the app to be opened. However, after closing the app AND exiting in App Switcher, breaks it. Only reinstalling or restarting the phone allows me to open the app again. While it is in its broken state, and not signed in, using autofill allows you to login. However, once logged in, it either works a few times or just keeps crashing the autofill.

I also managed to pull out a [crash log].(hastebin)

I swear every one of the six thousand apps I have have been updated at least twice through the 15 beta and BW hasn’t even updated once :frowning: this issue is super frustrating and inconvenient

TestFlight link for updated builds:

1 Like

In the same boat as others