App failing on Fedora 38

After updating my Fedora 38 system today, the Bitwarden client fails. As soon as I try to login, most of the app’s window goes blank, and there’s no functionality, even though the window is still up on the screen.

I’ve tried both the unofficial Flathub version and the official AppImage version. I’ve also tried rolling back to an earlier version of the Flathub version.

I can see the error message when I run the AppImage version, but I don’t understand it. Here’s what I get.

I’m not sure what to do – I really need Bitwarden working in order to get anything done on my computer.


17:57:35.771 › Checking for update
17:57:36.714 › Update for version 2023.9.2 is not available (latest version: 2023.9.2, downgrade is disallowed).
17:57:48.900 › TypeError: Object has been destroyed
    at WindowMain.<anonymous> (/tmp/.mount_Bitwarve0ZQ4/resources/app.asar/main.js:46720:36)
    at (<anonymous>)
    at /tmp/.mount_Bitwarve0ZQ4/resources/app.asar/main.js:46494:71
    at new Promise (<anonymous>)
    at window_main_awaiter (/tmp/.mount_Bitwarve0ZQ4/resources/app.asar/main.js:46490:12)
    at WindowMain.updateWindowState (/tmp/.mount_Bitwarve0ZQ4/resources/app.asar/main.js:46715:16)
    at WindowMain.<anonymous> (/tmp/.mount_Bitwarve0ZQ4/resources/app.asar/main.js:46649:28)
    at (<anonymous>)
    at /tmp/.mount_Bitwarve0ZQ4/resources/app.asar/main.js:46494:71
    at new Promise (<anonymous>)

I’m having the same problem running Bitwarden desktop on Pop!_OS 22.04.
Login screen can be made to reappear for a second by refreshing using Ctrl-R and the app seems to know which server to talk to but it disappears before I can enter more than a few characters of my password.

I uninstalled the current Flatpak version and tried using the Appimage but both behaved the same way.

I’ve been using Bitwarden on Fedora 38 for some time and it worked flawlessly. It was the last update that broke the app for me.
I am encountering the same error you do.

1 Like

I think a lot of people are having the same problem. There’s a bug report for this filed at github, so I think the developers know about it. I hope they get it fixed soon.

1 Like

For reference Linux Desktop Client blanks out when entering vault key · Issue #6560 · bitwarden/clients · GitHub

I’m also having this issue in Pop!_OS 22.04. I’m having other issues with this last update but it seems like there must be a separate cause for Bitwarden.