Android app match detection in browser set to starts with

Yesterday, I was cleaning up my vault’s URIs and making sure they point to the correct login page. My plan was to use the starts with match detection option. For some reason though, it won’t when using a browser in Android where I am using the keyboard. Neither through the in line key board, nor through anything else.


Browser: Brave
URI in Bitwarden:

Screenshots with match detection set to “starts with”

Screenshot match detection set to “Host”

Is this perhaps because Bitwarden doesn’t detect the “https” portion of the URI?

Could you screenshot this to verify? Are you sure there is no trailing backslash, for example (

In a Chrome browser on a Windows PC, using Starts With for the URI does work, so it may be some weird Android issue.

1 Like

No trailing backslash.

Thanks for providing the requested information. In that case, your best hope is that someone who has experience with doing match detection on Android will stop by and help. Per the documentation global and custom match detection options are supported in the mobile apps, so there appears to be some idiosyncrasy at play here.

I tried the exact scenario on my Google Pixel 5a (Android 13) and I had the same problem that @Unissued7022 described. I have not tried to see if the problem exists for other websites or other URI matching options.


I ran into what seems to be the same issue. The issue seems to be the combination of filling from the keyboard (as opposed to the popup), and using “Starts With”:

This behavior seems to be related to Issue #1946 on GitHub: