Yubikey WebAuth not working for 5th Key

I have 5 Yubikeys defined. When using to login, one particular key always fails to work, it says it isn’t registed with Bitwarden, however it is. I’ve deleted it and re-added it, but it still fails. All the other keys work, I was thinking that maybe the key was defective somehow, but it works fine with Google and Github. Any ideas? Thanks!

I tried deleting a few keys and then re-adding in different slots, i.e Key 1 and Key 3. Now when I try to authenticate with the problem key, it gives me an “Invalid State Error”.

I have checked the key at demo.yubikey.com and it works fine.

Hi Gerald,

Very odd behavior here but I am no expert on Yubikeys by any means.

Could you perhaps try and test the problem key at the Yubikey Webauthn demo site and see if that is successful?


1 Like

Hi Kent, thanks for the reply, I was just updating the question when you responded. Yes, I’ve checked that the key is good at demo.yubikey.com; so it appears to be an issue with bitwarden. As I said, the key also works fine with Google and Github.

Ahhh glad to hear you were able to confirm, I know you said it worked correctly for some other services but thought it best to double check.
I was able to locate a similar issue related from another user’s post here.

Consensus here would be to contact Bitwarden support directly for technical support as this would most likely be a backend issue that they will need to help resolve.

Let us know how it goes and if it gets taken care of, would be interested to know as it appears to have come up for some users occasionally.

Will do, thanks for your help!