Windows security pops up instead of bitwarden when passkey is required

I have a passkey that I stored on Bitwarden for a web site, I initially set up the passkey on my mac.
When I try to access the same web site from my windows PC, the web browser pops up Windows security instead of Bitwarden.

The Passkey is properly synced in Bitwarden.
I am using edge on both computers.
I navigated the settings on Edge, Windows and Bitwarden, but I can’t find how to fix this behavior.

Anybody can point me in the right direction?
Thanks,

Roberto

@montan Welcome to the forum!

The most likely culprit is the domain exclusion list. Go to Settings > Excluded Domains, and look for the problematic domain there. If you find it, delete the domain from the exclusions list (by clicking on the red circled minus sign). You may or may not need to sync your vault or restart your browser for the change to take effect.

Good catch! Thank you
I removed the site from the list and it now works as charm.
I also found in the list another site that gave me issues with passkeys.

I now wonder how they got into the list in the first place…

Good for you, that that was the solution!

Maybe just for other readers: It could be the website / “account” as well. Just the other day, I created a passkey for an account and could successfully store the passkey in Bitwarden. And the first login to the service work well with that passkey. Maybe it was, because when I close my browser, all cache, website data and cookies is deleted - I can no longer use the passkey in Bitwarden to login to that service. Only Windows security pops up (just like your problem) - and not the Bitwarden popup. The website is not in my excluded domains. My best guess is, the website has not implemented the login process for passkeys very well yet and somehow sends the request directly to the OS (Windows Hello), so that Bitwarden can not “catch” the request properly?!.. Or has anyone another idea?

One way that this can happen is if you click the option “Use your device or hardware key” when you get Bitwarden’s passkey pop-up:

 

If you select “Always”, then the domain is added to the exclusions list.

Likewise, if you are prompted by Bitwarden to save a password, and you select the option to not ask again for that website, then the domain is added to the exclusions list.

@Nail1684 I’m marking this topic as solved, since OP’s issue is fixed. If you want assistance with the problem you’re experiencing, feel free to start a new thread, and share the URL of the problematic site there.

Okay, no problem - and I’ll think about opening a thread myself.

I had the same issue where I can consistently register a passkey but login would NEVER pop up. It was always windows security.

I have 1 site in my exclusion list and it was some random site that had nothing to do with my other sites.

I deleted this entry and saved it. Now I have NOTHING in the exclusion list.

Everything works fine now.

Seems a little fragile to me.

I actually clicked this, is there a way to undo it?

@Kaiwal_Panchal Welcome to the forum!

Yes, you can undo it by going to Settings > Notifications > Excluded Domains and deleting the website in question from the list of exclusions.