Unlock with biometrics no longer automatic

Macbook air M2
Recently when I want to unlock my vault with my finger instead of it automatically popping up, I have to manually click ‘unlock with biometrics’

Not the end of the world, but still would be better if it worked as before

1 Like

The same thing happened to me on Windows with the latest update of the desktop app to version 2024.3.0.
It had been causing problems for a while, but now it has stopped working.
I have reinstalled the plugin in Firefox and it has not solved the problem.

I just reinstall an earlier version (I am not sure that I had installed) the 2024.2.1, and still does not work.

With the plugin version for Firefox Version 2024.2.0, and the 2024.2.1 desktop version operates again. Not very good, sometimes it fails, (really has been failing) but at least the verification jumps.
You can try the corresponding versions for macOS to see if you can solve it.
Wait for these inegration problems, they are quite annoying, and I have lost a lot of time that should be dedicating to something else.

Running into the same issue (macOS)—all of the sudden it takes an extra click and it’s throwing my whole day off. I’ve tried resetting settings and such but no luck. :melting_face:

Same here, came to see if this was a known issue (this thread shows it is) and if there was a solution (none so far). The extra click is really annoying, partly because I have muscle memory of not needing it.
(window 11, Chrome Version 123.0.6312.59 (Official Build) (64-bit))

I would also like to point out that the automatic copying of a 6 digit two factor has borked as well. When you paste, like 1 or 2 numbers paste. so you have to go into bitwarden, click unlock with biometrics, then do you finger print, then click the copy of the two factor then paste.

Its like they are trying to make it as hard as possible for no reason.

Make sure that Settings >> Options >> Copy TOTP automatically is checked. Recent updates have been clearing the auto-fill/copy settings.

I am pretty sure that this is an intentional change, positively affirming that you wish to authenticate and not just that the camera is facing you.

For those of us that use fingerprint and not camera authentication, it is a poor quality of life change. Hard to accidentally scan your finger.
If this is indeed intentional for the reason stated, please make it configurable.

To unlock my vault I use biometrics.

To unlock with fingerprint requires I click on that option below password entry before applying finger to sensor is recognised. This is contrary to the way MacOS normally allows immediate fingerprint ID.

To unlock with Face ID requires nothing but looking at my device, as one expects in iOS.

If it is an intentional design change then it appears to be the logical opposite of what might make sense (as @SomeKindOfNonymous comments), or show consistency with Apple operating systems at least.

I am talking about MacOS, i.e. fingerprint. There is no logic what so ever to making me do an extra step, I invite the team at Bitwarden to explain how that is in any way useful what so ever to anyone, ever.

As for the 6 digit thing, thats a bug. as detailed it sometimes copies some numbers, 1 or 2, but not all six.

At the top of the page is a “bugs” link. Submitting a proper bug report will much more quickly get the developer’s attention.

Compliance.

NIST SP.800.63B is an authoritative document for authentication requirements. The old version states:

presentation of a biometric may or may not establish authentication intent. Presentation of a fingerprint would normally establish intent, while observation of the claimant’s face using a camera normally would not by itself.

While this does certainly support your case for eliminating the click before fingerprint, things get a bit more complicated because a new version is on its way out, which removes the examples:

presentation of a biometric characteristic may or may
not establish authentication intent

This leaves developers in a quandary. Do they add a step that moots “may not establish”, or do they pick a fight with the auditors regarding when it applies?

Created an account just to share the good news: turn the “Ask for biometrics on launch” setting on and it works again!

Was super frustrated with this change too for past few months and just found this out. Enjoy everyone!