Stuck on "awaiting confirmation from desktop" chrome extension

When I turned on my computer, the bitwarden desktop app requested to restart to install an update.
After doing so, I can no longer use windows hello to unlock the browser extension. it still prompts me with the windows hello dialog box, but after authenticating with that, it still simply says “Awaiting confirmation from desktop”

one thing to note, if I log into the extension with my master password, and then lock the extension through the extension settings I can use windows hello to unlock it, but if I restart my browser, I am back to square one.

Things I’ve tried so far:
removing and reinstalling the chrome extension
disabling and re-enabling autofill and unlock with biometrics.
syncing the chrome extension.
rebooting windows.

any suggestions on what I could be doing wrong would be greatly appreciated!
thank you in advance!


Had similar issues getting windows hello to work with browser integration in the new desktop app.

Try to reinstall both the browser extension and the desktop app, this seemed to work for me. Chromium (Chrome, Edge tested) browsers seem to now require allowing permissions for the extension to communicate with native apps on your computer.

I have just tried reinstalling both the desktop app and chrome extension about 3 times each. I also tried to use the store app, but that does not support the browser integration.

it’s just weird how it used to work perfectly fine and now it just acts like I never authenticate with windows hello, but it does connect with the desktop app.

biometrics will work if I first unlock with the master password in the same browser session(locking it through settings, which I never have a use for), but at that point, it’s useless.

Same issue here since the latest Chrome extension update today.
Also getting ‘can’t decrypt’ error for all logins. A full logout and login (not just a lock) seems to fix the ‘can’t decrypt’ error but it comes back again.


We’re on the case and working to remedy this asap.


Having same problem on macOS.
Unlock with biometric stops at “Awaiting confirmation from desktop”.
I tried reinstalling desktop app and the extension.
I had to uncheck “Unlock with biometrics” option for the browser extension.
MacBook Pro (13-inch, 2020, Two Thunderbolt 3 ports)
macOS 12.1
Bitwarden: Version 1.30.0 (1935)
Google Chrome: Version 98.0.4758.80 (Official Build) (x86_64)
Bitwarden extension: Version: 1.56.0

I’m facing the same problem. For whatever reason also the TOTP copy button is greyed out for me in the browser extensions since then.

1 Like

[Added: It appears that my problem is related to this thread:
Stuck on "awaiting confirmation from desktop" chrome extension - #2 by cksapp]

FWIW, I installed the new version of Bitwarden last night when prompted. This morning, fingerprint unlocking no longer unlocks Bitwarden – neither the desktop app nor the browser (in Vivaldi) responds to fingerprint unlocking. Fingerprint unlocking still works to access Windows itself.

When I click the icon in the browser, or use the desktop app, and select “Unlock with biometrics”, the usual Windows Hello popup pops up, and when I supply my fingerprint, the Hello popup disappears (which means that my fingerprint was accepted), but Bitwarden does not unlock.

Curiously, the browser add-on gives a message that it is waiting for the desktop app to become active, but it is already active. And even more curiously, the Windows Hello popup pops up even though the browser app says that it’s waiting for the desktop app to become active (it usually doesn’t cause the Hello popup to pop up if the desktop app isn’t active).

Added: I’ve just noticed something else that is odd. Usually, when I click the icon in my browser, it asks for my master password and then I have to click the “Unlock with biometrics” button before the Windows Hello popup pops up. But now, the Hello popup pops up immediately (i.e. I don’t have to click the “Unlock with biometrics” button).

Additionally, if the desktop app isn’t running, then the browser app pops up that message telling me to start the desktop app, but it appears to be in a loop because it pops up over and over and over.

The behaviour is different each time. Sometimes the message “Awaiting confirmation from desktop” pops up before the Windows Hello popup pops up, and sometimes Hello popup pops up without the “Awaiting confirmation from desktop” message. Sometimes, when I click Cancel in the Windows Hello popup, it simply pops up again (as if the browser is causing it to pop up again).

Sometimes, even after I’ve added the master password and gotten access to my passwords, the Windows Hello popup keeps popping up again and again.

Where can I find the previous version of Bitwarden, so that I can upgrade back down to it?


This started to occur to me as well. I removed the chrome extension and re-installed and that seemed to do the trick.

1 Like

This worked for me. Not sure if it makes a difference but after uninstalling the chrome extension, I also restarted Windows. Once re-installed, bitwarden seems to be working correctly again. So far, anyway.

It apears that version 1.56.2 of the Bitwarden extension is now rolling out in the Chrome web store, and this updated release fixes many of the problems people are experiencing. If you are having difficulties, removing the extension from Chrome and installing this version may help.

From the BW Github page, release 1.56.3 is out now, which fixes even more issues - hopefully it will appear in the Chrome store shortly.

Same issue here. Bitwarden 1.56.1, macOS Big Sur 11.6.3, Google Chrome 98.0.4758.80. Kindly release a fix asap.

@kevinpop - see my post preceding yours.

1 Like

Thanks. Gonna try. Much appreciated!!

1 Like

Updated chrome extension and desktop app and still have the same bug.
I’m on desktop version 1.31.1
Chrome extension version 1.56.3
I am now getting “Browser integration is not enabled” message even though I have it enabled in the desktop app. I tried turn it on and off again in the desktop app but had no luck.
Any other ideas?

Suffered the same issue as TE, completely removed plugin out of chrome and reinstalled over chrome plugin store, now workin again like a charm.

Could anyone please educate me on why I’m not seeing the chrome extension version 1.56.2 and 1.56.3? I can only see 1.56.1 in the chrome extension store and the issue persists after several times of re-installment

I had same issues just now Decryt and Windows hello freeze. Several version changes look to have occurred over Browser/ Desktop. Edge continued to work but Chrome failed.
Removed extension - closed browser - cleared cache reinstalled version off Bitwarden site. 1.56.1 and Chrome has updated to Version 98.0.4758.82 (Official Build) (64-bit). Also on the PC desktop updated to 1.31.1.
Closing and restarting (clearing) your Chrome after each modification is usually good practice due to caching. Each system fix can have slightly different fixes, but 56.2 and 56.3 may be attempts to solve the mixed version issues occurring. Hope this helps

1 Like

v1.56.3 is available on github directly, but is also in the process of being sent to the chrome web store, too.

I am running 1.56.4 from the github, but I still can’t enable Unlock with biometrics.

Auto Fill on Page Load also doesn’t seem to work on pages where it always worked before.