[SOLVED] Send feature in self hosted version of Bitwarden update (2.17-2.19)?

Hey guys,

I’ve tested the online feature for sending passwords to single users and that’s what I needed in my company. We have installed Bitwarden server version on our premises and I would like to have this feature there as I need to provision single passwords to users. I’ve updated Bitwarden but it only self-updates to version 2.18.1 and I’m not sure why is the self update only reaching to version 2.18.1 and how can I install 2.19 on premises?

Thanks for your answers!

Also using a self hosted version. I updated today hoping it’d be rolled in, though it doesn’t look like it.

Did you update the server to version 1.40.0? It was released yesterday

hey, thanks for the answer.
I did
sudo ./bitwarden.sh updateself
Which gave me:
_ _ _ _
| |__ () |__ ____ _ _ __ _| | ___ _ __
| ’
| | \ \ /\ / / | '__/ _ |/ _ \ ’
| |) | | | \ V V / (| | | | (| | / | | |
/||_| _/_/ _,|| _,_|_
|| ||

Open source password management solutions
Copyright 2015-2021, 8bit Solutions LLC
https://bitwarden.com, https://github.com/bitwarden


bitwarden.sh version 1.39.4
Docker version 19.03.6, build 369ce74a3c
docker-compose version 1.21.2, build a133471

Updated self.

Not sure if bitwarden.sh in Version 1.39.4 is correct and maybe should manually be updated to 1.40 or something?

After that I’ve done
sudo ./bitwarden.sh update

Ran smoothly but only updated from 2.17 to 2.18.1 instead of 2.19. Tried second time with same result (Thought maybe I need to update to 2.18 first and then to 2.19).

Anything I’ve missed here?

The same problem here.

When I performed with update and updateself the latest version I see is 1.39.4 and not 1.40.0 (Tags · bitwarden/server · GitHub)

Same issue… i downloaded the server zip directly from github and the bitwarden.sh is still the older 1.39.4 version

Apparently someone forgot to update the script ?

If you’re too excited (like me) and want absolutely the last version you just have to modify your bitwarden.sh file and change these two variables:




And then:
./bitwarden.sh update # without the updateself or you will lose your modifications

At your risk of course (but it work great here :slight_smile: )

Hey Stratos,

thanks! This one worked!
I’ve tried with “2.19” and “1.40” which didn’t work but your correct assumption was the solution!
What a dev blunder! :wink:

Thanks and have a great weekend!

I did a self-install on Ubuntu a few days ago, pulling from git, and I don’t see the update script. Help!