Safari missing browser extension

Perfect. Good job! I had to do all you suggested David H; Upgrade to 1.29.1, reregister launch services. I also had to re-enable the bitwarden extension in Safari->Extensions, relogin when the bitwarden icon appeared next to the safari address bar and re-enable biometrics for login in the bitwarden extension settings. (BigSur 11.6, Safari Version 15.0 (16612., 16612), MacBook Air (M1, 2020))

1 Like

I’ve just downloaded the Bitwarden update and the Safari extension is back and working well. Thanks.

1 Like

Works for me too :slight_smile:
Many thanks to the Bitwarden team!

1 Like

Monterey 12.0.1 with Safari 15.1 on M1 Pro, extension is still not showing up after latest update from Apple Store.

Just so it’s on this thread as well - if your extension is still missing, you may need to correct the launch services by running this in the terminal app:

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user


Not feel comfortable working in terminal……

It should work as is from Apple store

Understood @mpv - the command doesn’t actually change anything in Bitwarden. It is a way to rebuild your “launch services” - which is what is keeping from Bitwarden from being displayed.

You can also use a utility called OnyX for macOS which has an option under Maintenance to perform this rebuild without using the terminal:

It’s working fine, here. Thanks for the update!

Same issue here. OSX 12.0.1 Monterey, Bitwarden Version 1.29.1 (1802). Safari extension just vanished today, tried the Terminal commands in this thread with no success. Two other extensions remain working perfectly in Safari.

Same issue, Mac Mini M1 OSX Monterey, Versió 1.29.1 (1802). I’ve tried Onyx and Terminal “solutions” but any of them work for me. Other extensions still run without issues.

Try to install the Safari Technology Preview, and see if the extension the loads. I noticed for some reason temporary installing this preview browser fixes issues like these.

Yes, with Safari Technology Preview, the extension loads and works properly… Thanks! But I think the extension should work with the original Safari, i hope this can be fixed and solved soon.

Please make sure to run the command as the affect user, I.e. no sudo. Unfortunately there’s not much we can do on our parts to address this, since it’s a macOS issue.

Do you know what causes this and/or did you file a bug report with Apple?

Like I said in the other topic, for me the problems started with Monterey and M1, and Bitwarden is the only extension that disappears from time to time out of several ones I have installed. It seems like there is something “special” about the Bitwarden extension. :sweat_smile:

We’ve filed a bug using the “Feedback Assistant”, but haven’t gotten any response. It’s also a documented issue on their developer forums.

And another extension developer suffers from the same issue, Disappearing Safari extensions

Bitwarden uses the new “Web Extensions” APIs, the non-dissapearing extensions are probably using the older App Extensions or the even older Legacy Safari Extensions.


It worked for me. Thanks!

Had the same disappeared Bitwarden extension in Safari but it resolved when I updated & upgraded to Monterey. Spent 4+ months away from home and could not update/upgrade during that time as no stable wifi available. Home in time for the holidays and so busy just assumed it was auto updating. It was not. Once this extension and a few others (Zoom & One Tab) also simply disappeared a couple weeks ago, I realized update might resolve. And it did. Hope this helps someone.

This also worked for me (clearing caches in Onyx)

The scary Terminal command worked for me, but it knocked out the LastPass extension I painstakingly installed less than hour earlier as an alternative to my preferred password manager!

It should reappear again shortly, or after a system restart. The older Safari extensions seems to take slightly longer to re-appear after resetting the launch services database.