Safari missing browser extension

I’m on a Macbook Air M1 with Big Sur 11.3.1 and the Safari extension is not available. I tried uninstalling Bitwarden using AppCleaner, rebooted the laptop, and re-installed via App Store. Still the extension is missing.

The extension is available and working in Chrome (arm64) and Firefox (arm64) though.

Hello Bitwarden Team,
first of all thank you very much for this good piece of software you developed for the Mac Owners.

Hello Francis,
I am still fighting against the Safari Extension too. I got it working, but unfortunately the Bitwarden-Safari-Extension disappeared the same way (without further notice). After another restart of Safari the extension was no more available. But why?
I removed the complete Bitwarden Application on the Mac Mini M1 and reinstalled the Application again. After the opening of the app, the login into my Bitwarden Account I closed the Application again and started Safari. But no change.
I assume this is the same behavior you already mentioned.

Do you got another hint?

1 Like

We’ve seen some reports that this is occurring for non-admin users, but the extension is showing up for Admins. Could you confirm if this is the case for you?

1 Like

I normally do not use the Administrator User / Privilege for my normal user. I do not want to make it easier for Malware or Viruses as it is. The Administrator or Superuser environment should not be used for normal usage of a Multi-User and -Tasking System.
Nevertheless, it is a good idea to execute Bitwarden and Safari as Administrator. I will test that tonight because I need first to finish my daily work.
Yesterday night I installed the Safari Technology Preview. Here the Bitwarden extension was able to be executed.

Thanks for the information! And I totally understand not using your administrator account, we are just trying to identify a trend :slight_smile:

Just clarifying, Safari Technology Preview DID work with the extension?

1 Like

I’m currently using an administrator account.

Thank you for the confirmation!

Thanks for this information, @neidsa. However, I don’t want to install yet another browser on my system. So far, the only browser affected on my system is Safari. It’s working fine in Chrome and Firefox.

I’ve solved the issue (Bitwarden Extension under Safari 14.1 (16611. on Big Sur 11.3.1) on Apple M1 from 2020. I’ve started Bitwarden as root (aka Administrator), logged in one time, closed Bitwarden Application again, started Safari (not the Safari Technology Preview), Opened settings, selected the extension tab and activated the Bitwarden Extension.
Hurray, it is working. Now I can remove all other browsers (Firefox, Chrome) from my system.

Hope it helps. My fault was, only to test the Safari / Bitwarden-Extension only on user level, not on Administrator or root level.

Maybe your account is named as an Administrator, but the privilege is still a standard user. As I prepared my Mac first time, I’ve created one user as my user account. The first account which will be created on a Mac is a Administrator user maybe named ‘Joe’

@hinton @cscharf :point_up_2:

Sorry, need to withdraw my previous hints. After the first try I logged out and logged in again. Unfortunately the Bitwarden extension disappeared from Safari again.

Tomorrow another exercise.

Sorry that I do not have better news.

I can confirm I am having the same issue on a 2020 M1 MacBook Air, running MacOS 11.3.1, Safari 14.1, and Bitwarden 1.25.1 (App Store download) - works fine in my Administrator account, but not in my own user account (the extension has disappeared from Safari, just recently).

As I only use Safari, it’ll be very good if this issue could be resolved quickly :slight_smile:

1 Like

Because of the missing comfort with Safari I switched back to Chrome. I hope that the Bitwarden Team will find a way to solve this issue.

It’s an admin account.

Screen Shot 2021-05-21 at 9.52.24 PM

from our GitHub issue, a user reported success by clearing some system caches:

UPDATE. I’ve used OnyX to clear caches and other system junk, rebooted and, suddenly, BitWarden extension reappeared in Safari. I’m happy, but have no idea what exactly helped.


I can confirm this works! Thank you! Hope you figure out what went wrong :slight_smile:

I tried all of these steps, Still can not get the Safari extension to show up.
I removed the old Bitwarden App, searched for all instances of Bitwarden, emptied the trash. Re-installed the Bitwarden from the AppStore. Ran it as admin using “sudo”… still didn’t show up. I downloaded the OnyX and tried that. Cleared out all the cache files. Still nothing. Anyone have any other ideas?

Big Sur 11.3.1
Safari 14.1
On Intel MacbookPro

I updated the MacOS 11.4 version. Safari 14.1.1 Inter Macbook Pro.
Bitwarden started to work fine Safari.

This appears to have worked for me too - many thanks for sharing!

1 Like