Safari missing browser extension

Now I am back on Safari (14.1.1) after I’ve updated Mac OS Big Sur 11.4. It is now the 2nd day after reboot, logouts including several restarts of Safari. Something changed. Either there was a change within Big Sur or the cleaning of Safari caches was part of the update procedures.

Nevertheless, now browsing makes more fun again …

1 Like

Same here, the Safari extension is missing - Bitwarden Mac App Store version, BS 11.4, admin account. Clearing cache didn’t help.

The Bitwarden extension has also completely disappeared from Safari in my 2018 Intel MacBook Pro. Restart did not work. I have Mac OS 11.4 and Safari 14.1.1

How can I fix this?

OnyX did the job for me.

I have a iMac, Big Sur 11.4, Safari 14.1.1. Bitwarden 1.26.5.

Safari extension is now missing. Was working yesterday; suddenly today it vanished from the toolbar. I won’t to Safari/Preferences/Externsions but nothing showing up there. I tried cleaning caches with Onyx, rebooted. Still missing.


I contacted Bitwarden support (and they got back to me within a half hour! Thank you) and they suggested I try installing the “Safari Technolgy Preview” version, and gave me a link to the download. I did do that and, viola, it worked! The extension installed in both Safari Technolgy Preview and my regular Safari. I don’t know why, but it worked.

(Also, I didn’t mention it before, but my iMac is a Retina 5K, 27-inch, Late 2014. So the issue is not just with the M1 Macs.)

Same problem on a Mac Mini M1 running Big Sur 11.4, and Safari 14.1.1. I tried clearing system caches, rebooting, and no change. Installing the Safari Technology Preview solved it.

Additional info for the QA team: I had Safari and the Preferences / Extensions pane open during the install, and the minute the Safari Technology Preview install completed, the extension reappeared in the Extensions pane. Additional info that may help: This is a brand new M1 with 10GbE, that shipped with The most recent point release prior to 11.4. I upgraded to 11.4, and then migrated all my applications and settings from another M1 Mini, that was already running 11.4, but which was not having the problem.

My Bitwarden Safari has disappeared too.

I tried to open as admin which my account should be anyway.

Last login: Sat Jun 5 14:23:59 on console

The default interactive shell is now zsh.
To update your account to use zsh, please run chsh -s /bin/zsh.
For more details, please visit
iMac:~ MyName$ /Applications/
-bash: /Applications/ is a directory
iMac:~ MyName$ /Applications/
(node:19144) DeprecationWarning: file property is deprecated and will be removed in v5.
(node:19144) electron: The default of contextIsolation is deprecated and will be changing from false to true in a future release of Electron. See [Discussion] Changing the defaults for nodeIntegration and contextIsolation to improve the default security posture of Electron applications · Issue #23506 · electron/electron · GitHub for more information
iMac:~ MyName$ sudo /Applications/
Illegal instruction: 4
iMac:~ MyName$

My Bitwarden Safari extension disappeared as well. I have reinstalled the desktop app from the Apple App store. I HAVE been able to re-enable it on the administrator account and another newer user account as well, but cannot get the extension to show up in the Safari Preferences/Extensions tab in my primary user account that I’ve been using for a while. So it’s only working on the computer, but missing from a specific user account. Any thoughts?

this happened to me today, I’m not entirely sure how to resolve this. Just like everyone else here, I’ve removed the app, redownloaded Bitwarden a handful of times and its not showing in my extensions on Safari.

I removed it using AppCleaner and it still does not work.

I posted an update on GitHub yesterday with the current status, Bitwarden 1.25.0 Extension not showing in Safari 14.0.3 on macOS 11.2.3 · Issue #1718 · bitwarden/browser · GitHub. In short we suspect the issue is a corrupt database in the Launcher Service on MacOS.

There are three current work-arounds:

  • OnyX and similar tools supports rebuilding the Launch Services database.
  • Install Safari Technical Preview, it seems to register itself as the new handler for Web Extensions. Which also makes the extensions available in the regular Safari application.
  • The following command seems to rebuild the Launch Services database and worked on my machine /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user. Note the command should be run in the terminal as the affected user. The machine may temporarily slow down and finder can take a moment to become responsive while it rebuilds the database again.

I have no idea what Terminal is or how to use it. This all sounds very technical perhaps beyond my pay grade. What does Bitwarden say?

Here you go @jamesjm

1 Like

Unfortunately all solutions are a bit technical. Onyx provides a graphical interface for performing various maintenance and configuration of macOS. Just make sure to only select “Launch Services database”.

Thanks a lot for sharing! Not only did this command solve the problem of the missing Safari extension, but it also helped me find the solution to another problem that was bothering me for over a year.

The extension is gone again. I used OnyX to rebuild Launch Service database , but this time it’s not working. Guess I’ll have to wait for the extension to show up like it does every now and then.

We have an update coming asap (in review with Apple now) that will address the issue.


Good news! Thanks for sharing.

1 Like

Fix is available now in BW version 1.29.1:


Great job folks!

Thanks for the effort and quick turn around.

1 Like