Remove requirement to click to unlock when Biometrics is enabled

I know this topic was discussed previously (in Remove the Requirement to Click the Unlock with Biometrics Button If You Have Biometric Unlocking Enabled and Automatically Select Biometrics for Unlocking when available). Shortly after it was implemented (on closure of the 2nd link above), I am confident all the workflow was running perfectly. However, I recently noticed that I now have to click the “Unlock with biometrics” button again after trying to Autofill with a locked safe.

System: macOS Monterey (12.2)
Browsers: Chrome 97 and Firefox 96

Steps to reproduce:

  • lock the safe
  • navigate to any page and use the autofill shortcut (Cmd + Shift + L)
  • notice a new page will be opened asking for the master password with the “Unlock with biometrics” button at the bottom, but the action will not be triggered until you click the button
  • if you click the button, then all resume as expected

Am I missing something, or was this working better and now it requires this extra click again?

1 Like

Strange - I wonder if it is something related to Monterey?

I am using Firefox 96 on MacOS 10.14 (Mojave) and it is all working fine using the latest Bitwarden extension (1.55.0).

Hm, 12.2 is out for not too long (I updated on 28/Jan/22). That’s a hypothesis, maybe it was working on mine 12.1 and stopped on 12.2. If anyone else can test and confirm…

1 Like

To avoid the additional button click you need to uncheck “Don’t ask for biometrical unlock on start” (maybe similar, I’m on the german locale).

IMO the text on that checkbox is somewhat misleading.

With that option unchecked the biometrical dialog pops up immediately.

1 Like

Oh nice. I thought this would ask for the password right after launching my browser (not intended). But you are right, the text is misleading – maybe “on start” should be “on activate”. In reality, it will ask for your biometrics just when you access Bitwarden for the first time.

Unchecking that box made it work as I was expecting. Thanks!