Passkeys support for mobile apps

For those of you having issues with Google Password Manager being the only option, even after adjusting the chrome://flags, some users over on reddit have reported that rebooting their phone fixed this issue!

Fails to set Bitwarden as Passkey Provider.

Xiaomi incompatibility? Seems like @gurkburk76 has same issue.

1Password has same issue it seems:

Thank you for reporting the issue! It sounds like there is a workaround described in the 1Password community post you linked. Have you tried to see if this works for you?

I’ve set Bitwarden as auto fill service, set enable passkey for 3rd party apps in chrome. But I can only see Google’s password manager. No Bitwarden shows up :frowning:

Try a phone reboot? Some users have reported this fixes the issue with Chrome not showing Bitwarden as an option.

Tried twice, does not seem to work.
Also tried If you're encountering Autofill issues with 1Password 8 on a Xiaomi device — 1Password Community but still no sign of Bitwarden.

Hi @Micah_Edelblut why is it working on GitHub but not Cloudflare?

It’s hard to say without examining the webauthn requests to see more of what is going on. I see that Cloudflare uses passkeys as a 2FA method, while Github supports both passkeys as 2FA or passkey login. Which are you using with Github?

Hi Guys,
I have been testing passkeys on Bitwarden beta and wanted to share my findings, I hope this helps:
• I have few Passkeys saved in Bitwarden using the desktop browser extension (prior to the beta release). I was able to use it on my desktop and thought would keep ready once Bitwarden starts supporting the feature on mobile. The same Passkeys are also saved in my Google Password Manager for day to days usage (prior to BW beta release)
• When I first tried to use the mobile app to login using passkeys, I was always promoted by Google Password Manager.
• I have changed the chrome://flags settings to enable 3rd Party Password Managers.I was still promoted by Google Password Manage when I tried to login using passkeys. However, within the same Google Password Manager dialog box, at the bottom, there is an option “Other Passkeys”. Clicking on this option triggered Bitwarden Passkey dialog box to popup.
• I have removed passkeys from my Google Password Manager and tried to login using passkey on multiple websites. Bitwarden popped up immediately and Google Password Manager stopped being displayed.
• At this stage, the only thing which was still not working is SAVING NEW PASSKEYS on mobile.
• After multiple attempts, I have found that going to Settings ->Apps->Bitwarden and enabling “Appear on Top” option, fixed the issue on my Samsung mobile. I am now able to login and save passekys on the beta version of Bitwarden. So fare, I have registered two passkeys on my mobile (BW Community and
• Passkeys are still not working on some website like Cloudflare, but this could be site specific issues.
Other observations:
• I have noticed is that Bitwarden takes about 3x times the time to complete login using passkeys if compared to Google Password Manager (slow but not significant). However, this is a beta version, and hopefully things will improve going forward.
• Bitwarden sometimes requires double attempts to login using passkeys. After completing the first attempt and expecting the login to be completed, you get prompted to login again. This has happened on Adobe website.


Login on GitHub and 2FA on Cloudflare.

I have noticed that setting the Chromium flag chrome://flags to (Enable for 3rd party passkeys) stops BW from saving passkeys on Android. When I chnaged the settings to (Enable for Google Password Manager and 3rd party), BW starts prompting to save passkeys on mobile. This works on both Chrome and Edge mobile on Android.


This seems to work with Chrome on

For Firefox we might need to wait for 1862132 - Firefox on Android 14, third party passkey vendor is not supported

Yes this also was the solution for me to creating Passkeys with Bitwarden in Chrome

Android 14 (GrapheneOS) here, I was able to enroll to beta and start using passkeys - but there was a usability issue.
Before the beta, I already had Bitwarden selected as my autofill app, and even though Bitwarden was selected as the autofill app, the passkey support did not work in the browser (Vanadium-Chrome) when I installed the beta.
I had to disable autofill in system settings and then select Bitwarden again. After that, passkeys started to work in Vanadium.

We are aware of an issue with non-discoverable credentials (passkeys for 2FA) and have reached out to Google about a fix. Unfortunately, in these scenarios, Bitwarden never receives the webAuthn request.


For HyperOS users, I received the update on my phone today, and Passkeys with bitwarden started working :slight_smile:

Also the link to the settings in the Bitwarden menu doesn’t crash anymore but it actually opens a menu I didn’t had before.

This is an interesting point I haven’t thought of.
I know Passkeys are associagted to a specific website (by domain name I assume?)
How do you solve this issue with Android apps then really ? Are you using some .well-known url on the domain name or something ? What does the spec have to say about it?

Yes, this is done using digital asset links:
android developer docs

1 Like

I am still getting the same error on HyperOS version