Option to adjust or disable UI animation

The browser extension UI animation is really slow and annoying. It would take a lot less time to quickly adjust a saved item if the next view is displayed immediately after I click.

So I think that it should be possible to adjust animation speed or simply disable the animation.

This has become a point of friction and irritation after some months of use for me too. The app in the browser (but also on my Android phone) feels overly slow and unresponsive due to the animations.

At the very least there should be an option available in the settings to disable all animations, although I think it would be wise to change the default behavior too.

My company is in the process of evaluating Bitwarden as the default password manager for our customers, potentially selling many Enterprise Licenses in the years to come. Other than the missing multi-account feature, this is the only pain point that we would like to see changed.

1 Like

Thanks for the feedback! Is this in all browsers, or just some in particular?

Hi, this makes the extension feel very slow for me too and is quite frustrating. Adding an option to adjust animations speed or at least disable them completely would be great.
This seems to be in all browsers.

1 Like

It happens for me in Vivaldi (a fork of Chromium), but I’m certain that it’s not limited to it.

Same in Firefox. I don’t think it’s the browsers, I think the animation is running at the planned speed.

I would prefer to be able to switch it off, it really slows down navigating the system.

There also appears to be a delay from mouseup until the actual animation triggers. It would be nice to be able to disable that delay as well.

1 Like

I agree that the zoom animation is bothersome! It’s my first day on Bitwarden after switching from LastPass and I’ve already searched the options for a way to disable the animation, and found this thread as a result of my google search.

1 Like

Me too!

I just moved from LastPass to a self-hosted Bitwarden (made really easy using Cloudron) last night and so far I much prefer it, but the animation when auto-filling forms is really annoying and just seems completely superfluous and pointless - I’d love to be able to disable it completely!

FYI I’m on Ubuntu 20.04 and Firefox 82.0 (64 bit).

Hi,can you add a option “Disable zoom animation when autofill” in bitwarden chrome extension?
When it is checked, just remove the css .com-bitwarden-browser-animated-fill or change the transform: scale value from (1.2, 1.2) to (1.0, 1.0) in https://github.com/bitwarden/browser/blob/master/src/content/autofill.css.

Thank you!
Wish bitwarden better and better!

I think this is maybe a duplicate of Option to adjust or disable UI animation but I’ve voted for both for good measure!

Please, please fix this. Either remove the animation, make it an option to turn it off, or at the very least reduce it to something like 20ms instead of 200ms.

Now I literally have to sit and wait for Bitwarden to fill the form fields before I can hit “Enter” to login…