No updates available beyond 1.30.4

Hi all,

System: Synology DS918+
Docker: 18.09.8, build 2c0a67b (not the latest for Docker, but the latest available in the Synology Package Centre)
Docker Compose: 1.24.0, build 0aa59064 (same as above, not the latest available but latest offered by the Package Centre)

After having used Bitwarden quite well for the last few months, I noticed that 1.33.1 has been released a couple of weeks ago but I’m still on 1.30.4.

Tried updating my self-hosted instance using the instructions here: https://help.bitwarden.com/article/updating-on-premise/ on my Synology DS918+ and no updates are available apparently? (no errors, just… nothing).

Everything works fine on 1.30.4 but as it’s ~6 months “out of date”, I’m trying to determine why the update portion of the script can’t see anything beyond 1.30.4. I’ve tried rebuilding as well and no dice. Would prefer not to have to build a new instance of Bitwarden,

Any ideas?

If you take a look into the bitwarden.sh script around line 40, does it contain the current version numbers? Should look like this:

COREVERSION=“1.33.1”
WEBVERSION=“2.13.2”

If not, bitwarden.sh updateself seems to fail. If the version numbers are correct, there are probably no current Docker images for the Synology?

Sorry for the delay.

Looks like the self update is failing, even though when I do a ./bitwarden.sh updateself, it doesn’t throw any errors. Just checked the script:

COREVERSION=“1.30.4”
WEBVERSION=“2.10.1”

As for the docker images, the latest version available is 18.09:

https://archive.synology.com/download/Package/spk/Docker/18.09.0-0506/

I assume manually changing these values to what you have added above might break things?

EDIT: Just tried manually changing the values, no difference.