iOS problem: syncing iOS app broken after latest update


#1

Hi,

Has anybody notices problems with syncing new or changed items in Bitwarden client on iOS (12.4) devices?

Every time I create a new item or change an item in the BW iOS (12.4) client they aren’t synced on refreshing or closing the app. I have to do a manual sync to save them to the server. And when I open the BW client app on another iOS (12.4) device the changes don’t sync either. I have to do it manually. It is stuck on the previous manual sync (see screenshot)

This seems to have started after the BW client iOS update of mid June. Before that it was working perfectly.

I don’t have an Android device to test so I don’t know if this problem is iOS related or a server problem (self hosting)

I have also notices that BW sync is still working fine on an older iOS (10) device with BW client version 1.12. So I guess the bug is either related to the latest version of BW client or Apple broke something again with the latest iOS version (12.4).


#2

same problem for me


#3

same problem here


#4

Have you tried resinstalling? Maybe something got screed up with your push notification registration. A resintall should cause it to re-register for push.


#5

yes, i’ve reinstalled, but the problem still exists.
i’ve activate too de push notification…


#6

Same issue here


#7

Doesn’t the automatic sync worked on a schedule, not on closing? I thought the manual sync was for people who didn’t want to wait for the automatic process.


#8

Yes, I have reinstalled the app and also re-register for push. But the problem exists. As I said before on a older iOS version no problem with syncing


#9

same here, plus - also people on reddit are complaining…


#10

I have the same problem, which seems to have begun on Aug 4th, which was the last time my iPhone Bitwarden synced, although it should’ve synced when saving new items (which it confirms that it has saved, but apparently only locally). I took a screenshot of the “last sync” page on Aug 10 at noon, and it last logged a sync Aug 4. That in spite of entering test items and other changes I had made in those 6 days.

My new iPad Pro showed a more recent sync from today, but it did not show me the test items I’d entered on iPhone.

The things that do not initiate sync right now are:

  1. “pull down” to refresh
    2). Entering new items that “save”
    3). Quitting app (which heretofore would sync any new item entered).
    Not anymore.

Unfortunate to have to do dig into settings and do a manual sync each time.


#11

Came here to post about this, but see it’s already been raised–is there a bug tracker where this should be mentioned, or is this forum it?


#12

Having read all of the above, I’ve had a look at two out of several of my devices that use Bitwarden (iPad 2 and iPhone 6). The iPad shows the last sync was on 31st July. The iPhone shows the last sync was on 8th August.
I added a test item on my iPhone. It showed up almost immediately on my iPad. However, the dates showing for the last sync on both devices hasn’t changed even though they have both clearly synced. Both devices were logged in to my account at the time and the Bitwarden app was open on them both.
I then decided to see if the sync still works if the Bitwarden app was closed on my iPad when I updated the test item on my iPhone. After updating the test item on my iPhone, I opened the Bitwarden app on my iPad and the test item had not updated, so the iPad has not synced after opening it. I checked that the test item had been correctly updated on the Bitwarden Chrome plugin on my PC and it had been updated.
I then added another test item, this time on my iPad. This was correctly synced with the server and appeared on my iPhone (the iPhone was locked, but the app was running in the background). However (and this is rather worrying), the original test item which had not previously updated on the iPad, still had not updated, even after the iPad has synced when it added the second test item. If it had synced the second item that I had added to it, why hadn’t it received the first test item that I had changed on the iPhone? At this point, performing a manual sync on the iPad successfully received the changes for the first test item.

To summarise, the iOS apps all updated automatically if they are open on the device, but not if the app was closed (swipe up). Even after a successful auto-sync, the app did not report the latest date and time of the sync. If the app is closed, it never updates new items after it is opened unless you perform a manual sync.

System: Bitwarden self hosted on Ubuntu 18.04.3, latest Bitwarden and Docker versions. Latest iOS versions on iPhone and iPad.


#13

I also wanted to ask why syncing to my iOS device doesn’t work automatically. When changing or adding an entry in the Windows app it doesn’t sync automatically to iOS app although push is activated for syncing. I have to manually sync entries in iOS app. Removing and reinstalling of the Bitwarden iOS app didn’t change anything…


#14

I just installed the latest update on iOS


and still experiencing the same issues

  • no push sync if updated outside iOS
  • no sync on app open (after force quit)
  • no sync on pull down guesture

Is this a bug or am I missing something?
(self hosted, websocket is working fine)

best regards, paradeiser


#15

This seems to still be the bug, as I’m also still experiencing problems and I’m not self-hosted.


#16

I also can confirm that the bug is still there. Just updated my BW today to version 2.2.1 (55). After updating I opened the app and there was no sync. (See screenshot). I had to do a manual sync.

I also can confirm that after doing a manual sync the sync date doesn’t change instantly one has to close the app completely and start it again to trigger a change of the date.

As I said before the old version of the BW app (1.15) is still working as it should, syncing automatically.


#17

I thought that the update fixed the problem for me. After force quit of the iOS app and reopen it all entries are synced… :confused:

When starting the app after force quit it takes some seconds to open. May be this is the point when the iOS app syncs the entries?