Error "Failed to fetch" in Chrome when logging in to BitWarden Vault after first logout

Hi all,

This is a follow up from this question, which is long inactive, so I preferred a new post.

I’m getting the message “An error has occurred Failed to fetch” when trying to login into BitWarden Vault in Chrome extension. I tried cleaning the cache and restarting the browser, but got the same results.
I installed the extension yesterday, used it normally throughout the day, then logged out. Today was the first attempt to login after a logout.
I also used in Firefox, in the same grounds - installed yesterday, used OK, logged out, then logged in today - and it’s OK, no errors.

What else can I try?

My setup:

  • BitWarden extension 2022.10.1
  • Chrome 107.0.5304.110
  • Firefox 104.0.1
  • Linux Mint Debian Edition 4 Debbie (based on Debian 10.2)
  • Kernel 4.19.0-22-amd64

Thanks a lot!

hi @EmersonPrado. Are you trying to connect to the Bitwarden servers to login to your vault, or are you self-hosting? If self-hosting, what version of Bitwarden Server are you running and on what hardware/OS?

In BitWarden servers. No server or desktop hosting from my own.

It sounds like it could be a network latency issue. Have you tried switching networks (e.g., wifi, VPN, mobile data, etc.)?

Do you have any trouble logging in to

I was on Wi-fi. I connected now via Ethernet cable, but it didn’t help.
I log in without difficulties.
One detail to notice is that the error message comes in way less than a second. Doesn’t look like a timeout or the like.
I also tried enabling the “Allow in anonymous browsing” (hope I translated right) setting, but it didn’t change anything either.

Since I logged in successfully in Firefox, maybe it’s not about the network itself, but some connection setting which can be different between browsers. The only noticeable ones I could think of are DNS and proxy, because I use a VPN to connect to the company services. But I can access anything outside the company in the same browser, so I assume it knows it should reach BitWarden servers with standard (not the VPN’s) DNS and no proxy.

OK, maybe check this setting in Chrome then:

Right-click BitWarden extension in Chrome. Select “This Can Read and Change Site Data”. What is the setting?

If it is set to “When you click the extension” then this could be the culprit.

Try changing it to “On all sites” instead and see what happens.

1 Like

That was it! Once I changed the setting, I could log in without issue, then use the credentials normally. Thanks!

But that leaves me a question: what is this setting for? I thought I could use it to avoid BitWarden to try to identify all sites, possibly making it lighter and more secure. Is it meant to a specific use case?

That is a Chrome setting that seems incompatible with most password managers, according to what I have read. I think it does work if you are religious about authorizing every page you visit BEFORE clicking on the Bitwarden extension icon. You may also have to reload the page before clicking the Bitwarden icon to make it work. But I will be honest in that I am not sure - I gave up using Chrome a long time ago for all the issues like this that seem to plague the browser, so I can’t even verify it myself. Sorry!

1 Like

Got it. Thanks a lot!