Desktop App on Linux Not Working

Noticed something was off when my syncing was failing when I was logged in and trying to update my vault using the desktop client for Ubuntu (snap). Logged out to see if that would fix it, but now the desktop app is not able to connect to the database. Makes sense because before it was loading the local copy. For whatever reason, it can’t reach the copy on the BW servers.

vault.bitwarden.com works fine for me, just not the desktop app.

Any ideas what is going on? Have I been compromised somehow?

Removed the snap bitwarden and reinstalled it. No difference. Pretty worrying because https://status.bitwarden.com/ says there is nothing wrong.

The browser extensions work fine. Not the Bitwarden app. Not sure what happened.

1 Like

Same here. Latest snap isn’t working(2024.3.2). I’m getting the following error message when I try to authenticate for the first time after installing:
An error has occured. Failed to decode access token: JWT must have 3 parts.
I’m connecting to bitwarden.com and using google authenticator för MFA.

1 Like

Solved the problem by installing the AppImage from Bitwarden.com

AppImage version works perfectly.

snap says it was updated just yesterday. See here: Install Bitwarden on Linux | Snap Store

Wondering if I should change my master pass - if it has been compromised from using that snap. Clearly it was not loading my BW database, so what was it doing with my login credentials?

Until now I had been using the snap thinking it was as official and legitimate as it gets. Specifically chose the snap over the flatpak because I don’t want my password manager updated by anyone but Bitwarden itself.

Going forward, will be sticking to the AppImage I think.

Curious to know about any other experiences with the latest snap.

Are you saying you think that the snap has been compromised somehow? Wow! Am I glad I’m using MFA to log on.

The BW Appimage should be GPG signed for verification. This is a security product and it only takes a few seconds to allow a user to be SURE their download has not been tampered with, including a simple download error.

Gary, I’m still trying to figure out what is going on. Why would the snap suddenly stop working no matter what I do? Everything goes fine and then it just spirals round and round never being able to connect to my BW database.

As I say issue was first noticed when I was trying to update an entry in my BW database by syncing it. Syncing it failed. So I thought for sure logging out and logging back in would fix it, but no. Countless removals and reinstalls and reboots, and nothing has worked.

Going to try logging out and trying the BW snap on another user profile.

That didn’t make any difference. Only other thing I can think of is that I increased my Argon memory setting to 256 MB the other day. Most doubtful the snap is incompatible with that, so still no clue what is going on. Browser extensions and AppImage work fine.

This is happening to me to on the desktop version on Steam deck (which is KDE i believe)

Installing via appimage did not fix the issue, I had to use vault.bitwarden.com

Issue is resolved after typing this:

sudo snap connect bitwarden:password-manager-service

See here: Error when syncing the vault. · Issue #8651 · bitwarden/clients · GitHub

Getting the same issue again. Anyone know what is going on?

As a backup I tried logging into my vault using a logged in browser extension. I unlocked it and now I have no entries in my vault…

Anyone else having such problems?

Working once again - both the browser extension and the desktop app. Could have been my VPN? I disabled it before trying to log in again as suggested here: https://status.bitwarden.com/

“If you are experiencing an unexpected error or access denied while trying to login, check if you are connecting through a shared public IP, VPN, proxy, or Tor.”

However, website hosted at bitwarden.com also was down momentarily, so who knows.

Main thing is that my access is fully functioning once again.

Same issue. Tried sudo snap connect bitwarden:password-manager-service . Did not work. Is there a permanent solution to this?

Same with, after I login in Bitwarden on Ubuntu 24.04, I can`t see the content of my Items. Using snap version 2024.4.0

I still see the issue on the Desktop app under Ubuntu 24.04 LTS. See attached reference, it spins forever.

@rob-nn , are you able to capture a screenshot of your error, I pasted mine, perhaps this can help the dev team solve it. Thank you.

I am also having the same issue both on Ubuntu 24.04 snap package and Linux Mint 21.03 flatpak.

Are you using the snap version?

Yes, it seems something is broken with the desktop app…the chime extension and Android app are working fine

Well, if you are using the snap the snap command should fix the issue.

sudo snap connect bitwarden:password-manager-service

Appears you need a new Gnome Keyring or KDE Wallet: Error when syncing the vault on Linux desktop · Issue #8651 · bitwarden/clients · GitHub

Which distro are you using? Besides manually updating your Keyring or KWallet, you can fix the issue through the latest Ubuntu LTS or KDE Neon.