Desktop App on Linux Not Working

Team, I think something was broken yesterday…today I just launhc the desktop app and is working as expected…perhaps something was broken at the bitwarden end and it has been fix. Thank you all.

Same here! I’m in Ubuntu 22.04.4 LTS

This helped me in Ubuntu 24.04

sudo snap connect bitwarden:password-manager-service

then log out from app and log in again. Now I can see all passwords.

Thanks,

3 Likes

In my case no way snap version works. Uninstalled snap version “sudo snap remove bitwarden”, downloded https://vault.bitwarden.com/download/?app=desktop&platform=linux&variant=deb and then go to download directory and exec “sudo apt install ./Bitwarden-2024.4.3-amd64.deb”.
Everything works fine now.

1 Like

Well, this is ridiculous. No version of BItwarden desktop works on my system (MX Linux - KDE). I had 2024.3.0 AppImage working, but now it throws a Javascript error. Newer versions appear to work until you try to save a change and the initial error of JWT needs 3 parts nonsense pops up. I’ll be glad to contribute any information you need to get this fixed, just tell me what you need. I don’t run Snaps, so that solution doesn’t work. I’ve also tried .deb packages. Let me know what I can contribute to get this fixed.

I had the same problem and fixed it with this:

mv ~/.config/Bitwarden ~/.config/Bitwarden.old

Now Bitwarden opens normally.

1 Like

Thank you so much! That worked for me. I’m now running 2024.4.3 successfully

UPDATE: It worked once. Now back to the JWT error. Closed, and now it just spins upon opening. Still screwed.

Reverting to 2024.3.0 and clearing the config directory has me running, but this is ridiculous.

Try all the different installation methods: AppImage, .deb, and snap:

Make sure you kill all Bitwarden processes and use this before each install:

mv ~/.config/Bitwarden ~/.config/Bitwarden.old

If that doesn’t work, try searching your system for any and all files related to the application and rename them similarly, using something like this:

sudo find / -type f -iname '*bitwarden*'

Just some ideas for ya. Good luck!