Can't enable browser extension biometrics

Signed up for an account just to thank you for this! Was struggling with this for days, and this worked!

In some environments “NativeMessagingHosts” in HKCU may be blocked for example by an admin. Policy for Edge: Microsoft Edge Browser Policy Documentation | Microsoft Learn

In this case the settings mentioned @dh024 can be put in C:\Programdata\Bitwarden\browsers instead of appdata folder
and in the registry, instead of HKCU use HKLM and point default to above path with the browser browsername.json

This solution should also make it work for all users on shared devices.


Many thanks @bwjli, this fixed the issue for me straight away when none of the other solutions in this thread helped.

1 Like

I’m battling with a similar issue - still getting the browser integration not set error message - but despite the following modification haven’t succeeded yet in getting biometric unlock to work in Edge browser extension:

  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Edge\NativeMessagingHosts\com.8bit.bitwarden pointing to “C:\ProgramData\Bitwarden\Browsers\chrome.json” (alternatively tried to name the file edge.json but no improvement)
  • chrome.json file present with “path”: pointing to “C:\Program Files\Bitwarden\resources\native-messaging.bat”
  • manual execution of native-messaging.bat fails with the following error (no main.js exists below app.asar folder)
C:\Program Files\Bitwarden\resources>native-messaging.bat
  throw err;

Error: Cannot find module 'electron'
Require stack:
- C:\Program Files\Bitwarden\resources\app.asar\main.js
    at Module._resolveFilename (node:internal/modules/cjs/loader:940:15)
    at Module._load (node:internal/modules/cjs/loader:785:27)
    at c._load (node:electron/js2c/asar_bundle:5:13339)
    at Module.require (node:internal/modules/cjs/loader:1012:19)
    at require (node:internal/modules/cjs/helpers:102:18)
    at 72298 (C:\Program Files\Bitwarden\resources\app.asar\main.js:54626:18)
    at __webpack_require__ (C:\Program Files\Bitwarden\resources\app.asar\main.js:54786:42)
    at 57940 (C:\Program Files\Bitwarden\resources\app.asar\main.js:43809:26)
    at __webpack_require__ (C:\Program Files\Bitwarden\resources\app.asar\main.js:54786:42)
    at 99726 (C:\Program Files\Bitwarden\resources\app.asar\main.js:43788:19) {
  requireStack: [ 'C:\\Program Files\\Bitwarden\\resources\\app.asar\\main.js' ]

 C:\Program Files\Bitwarden>
  • native bitwarden app installed from their website
  • windows hello in native app working
  • browser extension installed via Intune (using ID jbkfoedolllekgbhcbcoahefnbanhhlh)
  • policy not allowing to install non system-level extensions
  • extension set to “allow access to file URLs”
  • native app set to enable browser integration.
  • prompt to allow bitwarden extension to communicate with native app: responded “allow”
  • users working with non-admin accounts

any programmers who know how to troubleshoot above Electron module error or any other hints on how to get this to work?

Thanks much!

For several times this is what fixed my problem, exactly like you said! Thank you

I had these policies set to not configured, setting them to enabled fixed it for me

Have you tried on a different pc?

On 4 yes. Disabling intune policy would resolve problem but is a bad idea in a SOC environment. Still waiting for bitwarden support to get back with a solution

What policy setting are you referring to?

This can work on hardened devices to. In some cases it’s up to you to define exclusions that your org accepts, for example if you follow CIS or some other framework. These frameworks does not demand you to be 100% compliant, deviations should to be well documented.

Native Messaging - Allow user-level native messaging hosts: disabled

Can anyone explain the solution to this problem in Edge in a simple way please?

Hey there, did you disable and re-enable the checkbox in both the browser extension and desktop app to activate biometrics?

Same issue with Brave browser. Seems to be a Chromium based issue Bitwarden is having. Tried every troubleshooting step, it’s getting very frustrating now.

Just flagging I had to do this on Chrome / Mac (M2). It’s June 2023 now,

Didn’t work without with zero useful error message. Worked with the workaround.

Work around that worked for me, both for Brave and Firefox.

  1. if Desktop App has “Require password of PIN on App start” under “unlock with windows hello”, uncheck this option.
  2. then, configure browser extension biometrics.
  3. after extension is set, enable desktop app option if you want.
1 Like

This fixed it. Thanks!

Despite following the procedure, app running, fingerprint scanner working, C++ redist installed, etc. described in the help article, the browser extension would still say it’s not set up in the app.

Go to the desktop app. Disable the option to allow fingerprint/biometric authentication in the browser.

Exit both the app and Chrome (completely, not to the tray). Run regedit and create the key and string values as described.

Restart the app, re-enable the option to allow authentication in the browser.

Restart the browser and enable fingerprint/Hello authentication in the extension. This time instead of the error it should ask you to confirm the fingerprint works.

Wow, that worked. Thanks

I’ve been running Bitwarden and the extension in Firefox for the last couple of years with absolutely no issues, using Windows Hello and the Allow browser integration option enabled in the desktop app.

As of a few days ago, this no longer works in Firefox. I mean, everything seems to work, to the point where the fingerprint login prompt comes up when I try to log into the extension in Firefox, it accepts my fingerprint, but then nothing happens - the extension does not unlock. In fact, I can’t even manually enter my master password because everytime I try to unlock it brings up the fingerprint prompt. I have to manually shut down the desktop app to interrupt communication between the app and the extension and then I can manually enter the master password into the Firefox extension and unlock it.

If I go through all the steps listed in the various posts here, up to and including uninstalling the extension altogether and running through setup again, it will work once, and then the fingerprint option goes back to the loop described above in Firefox.

Checking the reg entries shows that the correct key has been created (which it has to have been or else the fingerprint prompt would not appear).

Chrome, meanwhile, works perfectly.

I did notice that in the desktop app, although I have “Ask for Windows Hello on launch” enabled, the desktop app does not ask me for this automatically on launch and I have to manually click on the “Unlock with Windows Hello” box

I haven’t changed anything in any of the browser settings either so I don’t understand what has happened here.

Agreed, same here. On Mac and FF. Biometrics has been broken for the last few days. Will also open a new thread since this is pretty old thread.

Fair point - I should’ve checked the dates, and the forums, and would’ve found more up to date posts on this issue. D’oh!

Hopefully next BW FF extension fixes the issue.