Can't enable browser extension biometrics

Aha! Your suggestion worked at the third attempt, when I disabled Unlock with Biometrics on both extension and desktop app, then closed and restarted the desktop app and the browser, and finally re-enabled Unlock with Biometrics on the desktop app and then the extension.

Thanks for the advice, much appreciated!

1 Like

Did you find a solution for this? I too have only firefox.json there and no chrome.json.

Issue dating back from 2021, and still no official fix, a joke. Having the same issue on Chromium based apps (Edge, Brave etc) on macOS.

Hey @nCode @Warden1, have you tried any of the steps listed above, including disabling/renabling and removing/reinstalling? You can also contact the official support team at any time at https://bitwarden.com/contact/

Any chance you can guys can step up and fix this, the merry go round between the app and the browser extensions is a joke but its not a funny joke.

Hey @garethsnaim1, while this feature is working for most users, I can understand how frustrating it can be for those that are experiencing an issue.

Rest assured your feedback has been passed along to the team, and if you would like to help us investigate, please add additional information to a bug report here that best matches your experience, or contact the offical support team any time at https://bitwarden.com/contact/ for troubleshooting.

Does this make it work for the Windows store version? Seems to only work with exe.

For Windows, specifically the one from the Bitwarden download page.

That’s the one used. But as shared in the pop-up, 'is currently not supported in the MS Store version


Hey @JDD, that is correct, you need the one from the Bitwarden website.

While that’s what I’m doing today, I’d prefer to use the Store app due to inherent security enhancements of modern Windows apps (APPX/MSIX) and the automatic update servicing of store apps via Windows. Is there a plan to address/fix this? Do you know if this in the product backlog?

I’m a Chrome user and tried the above fixes, but since I didn’t have a chrome.json, it didn’t work. What did work was disabing the browser integration and then re-enabling it. When the browser integration was disabled, I noted that both the aforementioned registry key pointing to the non-existent chrome.json disappeared as well as the firefox.json file in the users roaming directory. I then re-enabled the browser integration checkbox. At this point, the same registry key was created but now the appdata folder contained both a firefox.json AND chrome.json.

I was then able to successfully enable biometrics in the Chrome extension. Hope this helps!

1 Like

That did the trick for me, thanks!

My suspicion: I installed the browser extension first. I vaguely remember seeing a popup there asking if I want integration with the desktop app. I just said yes. Only afterwards I installed the desktop app. My guess is that that brought me to this situation.

(by the way, I applied your fix in two steps: the first time I did not check ‘Require verification for browser integration’, I only did that after I saw it working. I don’t know if that is relevant)

I’m also having this problem on Edge. When I click “unlock with biometrics” it immediately locks the extension, and when I log back in, it won’t activate any more saying that its not enabled in the desktop app, but it is. I am an MSP testing this for a number of clients, so I need to be able to get this working.

Edit: Ignore me, some idiot hadn’t left Threatlocker in install mode long enough.

For Windows Chrome users, it seems that the chrome.json file does not get automatically created on-the-fly when installing the Bitwarden desktop app and enabling browser integration after having already installed the extension in Chrome and having the browser running. Here’s what worked for me without having to restart anything:

  1. The com.8bit.bitwarden registry key you are looking for is in
    HKEY_CURRENT_USER\Software\Google\Chrome\NativeMessagingHosts\
    (If this key does not exist, create it by right-clicking the NativeMessagingHosts key and pointing to NewKey and name it com.8bit.bitwarden.

  2. Make sure the value of the (Default) key is C:\Users\<YOURUSERNAME>\AppData\Roaming\Bitwarden\browsers\chrome.json (If it is missing, double-click the default value and enter it.)

  3. Create a new text file with the following contents:

{
  "name": "com.8bit.bitwarden",
  "description": "Bitwarden desktop <-> browser bridge",
  "path": "C:\\Users\\<YOURUSERNAME>\\AppData\\Local\\Programs\\Bitwarden\\resources\\native-messaging.bat",
  "type": "stdio",
  "allowed_origins": [
    "chrome-extension://nngceckbapebfimnlniiiahkandclblb/",
    "chrome-extension://jbkfoedolllekgbhcbcoahefnbanhhlh/",
    "chrome-extension://ccnckbpmaceehanjmeomladnmlffdjgn/"
  ]
}
  1. Save as %APPDATA%\Bitwarden\browsers\chrome.json (don’t forget to change the file type to “All types (*.*)” or you may save it as chrome.json.txt!)

  2. You should be able to go back to the extension and enable biometrics at this point. If it still doesn’t work, something else is going on for you and is beyond the scope of this writing. (The important parts of my post really are the registry key/value location and the contents of the chrome.json file!)

1 Like

I had the same issue on Vivaldi.
I applied the exact same fix as for Chrome.

I thought it worked, but each time I restart the browser I have to confirm the fingerprint in the Bitwarden desktop app before Hello appears. Is this normal?

Thanks!

You may need to check in your desktop app that the setting for Require verification for browser integration is disabled if you do not want to have this confirmation shown each time.

This: https://bitwarden.com/help/biometrics/
I had similar problem as noted by OP. The above link to detailed instructions solved the problem I was having. While this link was posted by @dh024 on 4/11/22, it may bear repeating.

This worked - thank you!