Bitwarden Passkeys No Longer Working

I’ve been happily using Bitwarden passkeys with the Chrome extension for some time. It all worked fine until suddenly, in the last couple of days, I started getting an error message saying “Could not complete biometrics. Try again.”. I don’t remember changing any settings so it’s a bit of a mystery to me.

Here is a screenshot showing an eBay login screen (I’ve blanked out my UID):

It’s happening with every site I’ve previously set up passkeys for in Bitwarden. I’m hoping there’s a simple explanation and quick fix!

For context, I’m using Windows 11 Pro and Chrome Version 126.0.6478.114.

Many thanks.

3 Likes

@bitmap The simple explanation is: Bitwarden introduced User Verification to passkeys, which is theoretically a part of the passkeys specs, so it is intended to have some form of user verification if any passkey is used.

Here you can see the announcement in the Release Notes for the 2024.6.0:

And here is the addition for the sign in-process in the Help Center:

You are asked for biometrics, because that is possibly your unlock method for the browser extension. (if you would unlock with a PIN, then you would be asked for that PIN…)

The good news is: if you do verify with biometrics, your passkeys all should still work.

1 Like

Is your Bitwarden Desktop app running and unlocked?

OK, thanks, I’ll have to read through that and see if it explains the error I’m getting!!

Yes, Bitwarden Desktop is running and unlocked.

In an effort to determine whether this might be a bug or not, perhaps you can try the following tests:

  • When you get the above error message, click the Use master password link — does the passkey work after entering your master passwword?

  • When you get the above error message, click Cancel, then lock your vault, and unlock it — are you prompted for biometrics to unlock your vault, and if so, is the biometric unlock successful?

Yes, the passkey works after entering the Master Password but if I log out from the site and try again logging in with passkey again, I get the same error message.

When I lock my vault and unlock it, yes, I have the option to unlock with biometrics and this works, i.e. it unlocks the vault. However, it still has the same problem with passkeys.

Thanks for the hints.

Some additional information…

I also tried to create a new passkey on passkeys.io. The Bitwarden chrome extension pops up and offers to Save Passkey, but when I click on Save Passkey, I get the same error as above.

Very strange!

To me, this has the hallmarks of a bug (and a reproducible one), so I would suggest reporting it as a New Issue on GiHub.

There is also a chance that there is some unusual configuration issue on your end, so it would probably be worthwhile to also reach out to Bitwarden’s customer support for assistance.

1 Like

I’ve raised it with customer support and I might wait for their response before reporting it as an issue, just in case I’m doing something obviously stupid.

Customer Support have confirmed this behaviour to be a bug. Here is their response to me:

Thank you for raising this issue. This seems to be a bug, and I will file a bug report for this issue. In the meantime, please use the Master Password option, and that should work as expected.

Let me know if you have any questions or if I can provide additional assistance.

Thanks,
Troy

1 Like

I too am getting the same behavior. The new UA mechanism prompts for biometrics, but can not complete the request, even though I can unlock the vault with biometrics and can still “passkey” using the master password.

Me, I have decided to give passkeys a rest for a month or two while they straighten things out. I am, in retrospect, very happy I did not go all-in by removing passwords from accounts.

2 Likes

I too have just started to experience this hurdle when logging into Google.

Passkey Verification By Device
Big problem for me, is that my PC does not have any biometrics. :cry:
Perhaps BW will provide a “biometrics with device” to work similarly to “unlock with device”

1 Like

Hi, did you get a github ticket? I am running into the exact same problem.

No, I wasn’t given a github ticket or any other reference number unfortunately. I’ll try getting back to the support team and ask them.

having the same issue…on Mac OS with Chrome extension

Facing the same problem on my mac. I’m using Brave & Firefox

Hello,
Just to confirm that I am also experiencing the same problem, testing on Chrome & Brave browsers.
The Desktop app is also open and unlocked and biometric identification enabled in the browser extension.
However, it works with the master password, apart from Google services where I can’t get passkeys to work at all on the desktop.

Do I need to create a ticket or has this already been done?

On or about June 20, Bitwarden customer support rep Troy said they were going to create a ticket, but their ticket (if it exists) cannot be found on GitHub. In the meantime, a user filed this bug report yesterday, which is evidently the same issue:

 

I would suggest that you comment there, if you have additional details to contribute.

1 Like

I’ve just received the following from customer support rep Troy:

Hi Martin,

This pull request should address the issue: [PM-8996] Revert user verification for passkeys by gbubemismith · Pull Request #9734 · bitwarden/clients · GitHub
Let me know if you have any questions or if I can provide additional assistance.

Thanks,
Troy

It seems the wheels are in motion. We just need a little patience…

2 Likes