Bitwarden not using latest password in iphone Safari

When I look at my bitwarden, it shows the latest sync time, the correct password and username for a site. I go to the site, it asks if I want to use the bitwarden correct username, I authenticate with finger, then it enters the old username and password from bitwarden that I changed an hour ago. I can look in bitwarden and see that old username and password listed under “password history” . I have icloud keychain turned off, the only thing in settings/passwords & accounts/autofill/ that is checked is bitwarden, so I don’t think the autofill is coming from someplace else. To sum up, bitwarden is sycned, when I look at it on my phone it has the current username and password, but when I autofill, it uses the prior username and password. what to do?

EDIT: nevermind, saw the last few rows in your post now and seems we dont have the same issue. :slight_smile:

have you tried pressing the sync button in bitwarden on the phone regardless that it says the latest sync time?

because the sync for bitwarden to the phone is worthless. i have more or less the same problem.
it says its synced (timestamp is after i made the change), but its not,. and not until i manually press the sync on the phone it actually syncs and the phone app gets the most recent changes.

and its been like this for me for at least a year or two. so dont have high hopes of it getting fixed either.

As described in a separate post, I had the same issue yesterday but it is gone today. Do you still have it?

I read nmbrg’s reply this morning where it was recommended to manually press sync on the phone, even though the date and time just below the sync button indicated that it has been synced well after the changes made. Anyway, I manually synced, and then the autofill worked with the latest username and password. I have no idea what was going on, it seems the automatic “sync” was only partially successful, but went fully through when manually told to sync again. The partially successful automatic sync did show that the site info in bitwarden had been updated with the new information, but when I went to autofill, it used the old information. So my problem is fixed for now, but it seems like a bitwarden flaw to me.

please see my reply to nmbrg

I also had such problems with new or changed passwords. In the Bitwarden app all passwords were there but when filling them into Safari the old password was filled in or there was no entry found. I think it must have something to do with the browser cache. When trying to login on the next day it worked. But where’s the problem? I don’t know… :confused:

You can read here:

There is an open bug report on GitHub too:

Hopefully this bug will be fixed soon. :frowning:

Again I run into this bug… But it happened on the iPhone of my wife. Every time I rave about Bitwarden how good it is and so on. Then I created a new login for her on a website in the Desktop app. She wanted to try it out and what happened? The new login didn’t work on her iPhone. So I synced the iOS app manually on her phone and the new login was there. There was 1 login for me and 1 login for my wife available in the app. But when trying to use the new login in Safari on her phone only my login was provided. The same with the app for this website. Only my login was provided. Really frustrating and now my wife is no longer so enthusiastic about Bitwarden. :frowning:

Please fix this bug!