Bitwarden Flatpak stuck opening vault - Failed to decode access token: JWT must have 3 parts

Hi guys!

So, a couple days ago, BW worked just like usual, but yesterday it looks like the desktop app (flatpak) got unsynced. So I logged out and back in. Now I’m getting this error (in the console): › Error: Failed to decode access token: JWT must have 3 parts
In the meantime, Bitwarden just shows an spinning icon trying to open the vault.

My browser extensions and the phone app work fine. Just the flatpak fails.
Any idea what might be causing this issue? I already tried uninstalling the app, removing all flatpak data and rebooting, to no avail.

EDIT: This is on Nobara Linux 38, KDE Plasma 5.27.9 and kernel 6.6.8.
A different machine, running KDE Neon with the same flatpak works just as usual.

Thanks!

I have the same problem.
On linux Ubuntu 22.04 - gnome 42.9 - kernel 6.5.0
With Bitwarden via snap package :
version 2024.3.2 / Shell 28.2.8 / Renderer 120.0.6099.291 / Node 18.18.2 / Architecture x64

Same problem here too… Started today.

On linux Ubuntu 23.10 - gnome 45.2 - kernel 6.5.0
Bitwarden via snap package: stable 2024.3.2

Same problem here. For me, the problem started yesterday.

I am using the snap as well
version 2024.3.2 revision 107, tracking latest/stable
ubuntu 22.04 using kernel 5.14.0

Issue with latest snap version (2024.3.2). Downgrade temporarily using sudo snap revert bitwarden

more helpful tips: Error when syncing the vault. · Issue #8651 · bitwarden/clients · GitHub

2 Likes

Thank you @jawesome that solves the problem in Ubuntu desktop temporarliy.

Information from the github issue thread posted by @jawesome, the problem can be solved by

sudo snap connect bitwarden:password-manager-service

Tried it, and it works :slight_smile:

3 Likes

This happens with the 2024.4.1 appImage also. How to fix?

Thank you! I ran into this problem on my Ubuntu machine today and this solved the issue.

Hmm, nothing works for me. After revert and/or snap connect bitwarden:password-manager-server, both fail to work with the API in any way.

– EDIT –

The following fixed it for me:

  • File > Log Out > (my-account)
  • Sign in again
  • File > Sync vault
4 Likes

100% confirmed!

Thanks, nothing worked for me either, but after logging out and then logging back in, everything is fine.

Hello, I am running 2024.4.0 on Ubuntu Linux installed from the latest/stable snap on Apr 11. My Bitwarden has been running fine for the last several days. However today I tried to edit an entry and I got this “Failed to decode access token: JWT must have 3 parts” error. I also got the error on creating a new entry. This thread recommended logging out and back in, so I tried that. However, when I logged in, I get only a rotating throbber where my password listing normally is. If I say File->Sync Vault it gives a popup saying “Syncing Failed”. I re-ran the Ubuntu software updater and rebooted the machine but it did not change the symptoms.

Post edit: I tried the sudo snap connect bitwarden:password-manager-service, then a new logout/login. Now everything works.

1 Like

I am using the appimage packaged client 2024.4.1. I logged out. Upon login the client appears stuck retrieving the vault data.

Update: In troubleshooting I uninstalled gnome-keyring, libgnome-keyring, and gcr; then reininstalled. I also disabled kdewallet and re-enabled, with reboots in between steps. Then I disabled hardware acceleration in the desktop client restarted. Vault login worked. I re-enabled hardware acceleration and restarted. Vault login works and syncing works. Not sure exactly what fixed things, YMMV.

Thank you, Tim! That solved my problem.

yes that solved my problem too :joy:

I dont have kdewallet, libgnome-keyring and doing the rest did not solve the issue

I logged out, then ran this command:

and bitwarden is working again.

1 Like

Most of the replies to this thread seem to be using snap, which is generally used on Ubuntu. If you’re like me, and you’re on a different distro like Fedora, and using flatpak, I had success with the following command:

sudo flatpak update --commit=47213097bc0383ffeff5b00d706d0eb121192449fe3cace77923ab879bc248c1 com.bitwarden.desktop

This will revert the Bitwarden flatpak to the version published on 2024-03-13, which is the latest working version I could find.

1 Like

None of the answers worked for me, I’m on Ubuntu 22.04.4 LTS
But this worked for me: Click on File (Fichier in french) > Logout (Se déconnecter in french)
Then reconnect, click on File (Fichier in french) > Sync Vault (Synchroniser le coffre in french)