Autofill on Android, password is filled instead of username

Autofill on Android, password is filled instead of username on Amazon, Google and probably some other websites.

Please implement the function to differentiate between username and password on webpages as this means on android websites such as Amazon cannot use the autofill function. I have tested both Lastpass and Dashlane on Android and these both handle the sequential type login boxes, i.e. a website presents first the username box then the password but only the password or the username box is visible at one time.

Please also refer to Github page which highlights the original issue as a bug but the bug was closed.

Just my 2 cents…

I have a Samsung S10 running Android and I was able to login to my Amazon account with the split serial Username and Password. I would recommend recording your URL, Username and Password for those sites, then deleting the entries in BW, then going to the site again and entering the login info and have BW record it again. This seems even more likely the issue if the login info was imported from another password manager. Its basically a reboot, if you get the analogy.

@Toons This was done under a brand new test account with only the Amazon account in it. I was looking at various UX / UI items for the various password managers available and the lack of desktop overlay (like android) and this bug / glitch / missing item was the other blocker to adopting Bitwarden as my paid go to for password managers. I have deleted the entry and re-entered and it still persists.

Are you using the inbuilt android overlay or the legacy accessibility option? I could not get the accessibility version to work at all on my android. Are you using Chrome or another browser such as Samsung’s one?

As yours works this appears to be a bug rather than a missing feature.

Hi Adam,

I installed the BW app recently but had never used it. I opened Amazon.com, clicked Sign-in, the BW pop up appeared to Auto-Fill and I press it and it filled the username. Password worked the same way.

Only thing I can think of is that I use DuckDuckGo for my search and it opens links in its browser, so maybe possibly its a browser issue.

Best, Toons

Hi Charles,

I have tried Duckduckgo browser and then gone back to Chrome and the Duckduckgo works and Chrome does not. Could you try Chrome to see if you get your password filled in instead of username?

If so we know for definite it is a bug and I will report it!

Yep I’ve also found some items fill OK on the desktop version of Chrome which then don’t fill correctly on the Android version. In particular one where I’ve had to create custom fields.

I was able to use Chrome and the BW extension to auto-fill Amazon.com on my phone. However, the behavior is slightly different compared to Duckduckgo’s browser. With Chrome, there is the BW popup over the username and password fields, but in each case when I press the auto-fill, it takes me to the BW app and I have to manually select the amazon saved item in order for it to fill. With DDG the popup allowed the auto-fill directly without a redirect to the app. So maybe that could be the issue, maybe a permission is blocking drawing on top of another app or the redirection from one app to another. I know I’ve turned off the draw on top of apps permission at times. Maybe try allowing full permissions to your browser and the BW app and see if the behavior changes.

Thanks, but have double checked and all autofill options are activated. I have exactly the behaviour you describe of having to pick it from the vault, however it then doesn’t autofill custom fields like it does on desktop.